summaryrefslogtreecommitdiffstats
path: root/src/spdk/test/app
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/test/app')
-rw-r--r--src/spdk/test/app/Makefile44
-rw-r--r--src/spdk/test/app/bdev_svc/.gitignore1
-rw-r--r--src/spdk/test/app/bdev_svc/Makefile65
-rw-r--r--src/spdk/test/app/bdev_svc/bdev_svc.c112
-rw-r--r--src/spdk/test/app/histogram_perf/.gitignore1
-rw-r--r--src/spdk/test/app/histogram_perf/Makefile55
-rw-r--r--src/spdk/test/app/histogram_perf/histogram_perf.c102
-rw-r--r--src/spdk/test/app/jsoncat/.gitignore1
-rw-r--r--src/spdk/test/app/jsoncat/Makefile55
-rw-r--r--src/spdk/test/app/jsoncat/jsoncat.c229
-rwxr-xr-xsrc/spdk/test/app/match/match326
-rw-r--r--src/spdk/test/app/stub/.gitignore1
-rw-r--r--src/spdk/test/app/stub/Makefile58
-rw-r--r--src/spdk/test/app/stub/stub.c147
14 files changed, 1197 insertions, 0 deletions
diff --git a/src/spdk/test/app/Makefile b/src/spdk/test/app/Makefile
new file mode 100644
index 00000000..e2ba6d0f
--- /dev/null
+++ b/src/spdk/test/app/Makefile
@@ -0,0 +1,44 @@
+#
+# BSD LICENSE
+#
+# Copyright (c) Intel Corporation.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of Intel Corporation nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+SPDK_ROOT_DIR := $(abspath $(CURDIR)/../..)
+include $(SPDK_ROOT_DIR)/mk/spdk.common.mk
+
+DIRS-y += bdev_svc histogram_perf jsoncat stub
+
+.PHONY: all clean $(DIRS-y)
+
+all: $(DIRS-y)
+clean: $(DIRS-y)
+
+include $(SPDK_ROOT_DIR)/mk/spdk.subdirs.mk
diff --git a/src/spdk/test/app/bdev_svc/.gitignore b/src/spdk/test/app/bdev_svc/.gitignore
new file mode 100644
index 00000000..77ddb987
--- /dev/null
+++ b/src/spdk/test/app/bdev_svc/.gitignore
@@ -0,0 +1 @@
+bdev_svc
diff --git a/src/spdk/test/app/bdev_svc/Makefile b/src/spdk/test/app/bdev_svc/Makefile
new file mode 100644
index 00000000..43ec095a
--- /dev/null
+++ b/src/spdk/test/app/bdev_svc/Makefile
@@ -0,0 +1,65 @@
+#
+# BSD LICENSE
+#
+# Copyright (c) Intel Corporation.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of Intel Corporation nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+SPDK_ROOT_DIR := $(abspath $(CURDIR)/../../..)
+include $(SPDK_ROOT_DIR)/mk/spdk.common.mk
+include $(SPDK_ROOT_DIR)/mk/spdk.app.mk
+include $(SPDK_ROOT_DIR)/mk/spdk.modules.mk
+
+APP = bdev_svc
+
+C_SRCS := bdev_svc.c
+
+SPDK_LIB_LIST = event_bdev event_copy
+SPDK_LIB_LIST += nvmf event log trace conf thread util bdev copy rpc jsonrpc json
+SPDK_LIB_LIST += app_rpc log_rpc bdev_rpc
+
+ifeq ($(OS),Linux)
+SPDK_LIB_LIST += event_nbd nbd
+endif
+
+LIBS += $(BLOCKDEV_MODULES_LINKER_ARGS) \
+ $(COPY_MODULES_LINKER_ARGS) \
+ $(SOCK_MODULES_LINKER_ARGS) \
+ $(SPDK_LIB_LINKER_ARGS) $(ENV_LINKER_ARGS)
+
+all : $(APP)
+ @:
+
+$(APP) : $(OBJS) $(SPDK_LIB_FILES) $(SPDK_WHOLE_LIBS) $(COPY_MODULES_FILES) $(BLOCKDEV_MODULES_FILES) $(SOCK_MODULES_FILES) $(LINKER_MODULES) $(ENV_LIBS)
+ $(LINK_C)
+
+clean :
+ $(CLEAN_C) $(APP)
+
+include $(SPDK_ROOT_DIR)/mk/spdk.deps.mk
diff --git a/src/spdk/test/app/bdev_svc/bdev_svc.c b/src/spdk/test/app/bdev_svc/bdev_svc.c
new file mode 100644
index 00000000..2db96d6b
--- /dev/null
+++ b/src/spdk/test/app/bdev_svc/bdev_svc.c
@@ -0,0 +1,112 @@
+/*-
+ * BSD LICENSE
+ *
+ * Copyright (c) Intel Corporation.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * * Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * * Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in
+ * the documentation and/or other materials provided with the
+ * distribution.
+ * * Neither the name of Intel Corporation nor the names of its
+ * contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+ * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ * OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+ * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#include "spdk/stdinc.h"
+
+#include "spdk/env.h"
+#include "spdk/event.h"
+
+static char g_path[256];
+static bool g_unaffinitize_thread = false;
+
+static void
+bdev_svc_usage(void)
+{
+}
+
+static void
+bdev_svc_parse_arg(int ch, char *arg)
+{
+}
+
+static void
+bdev_svc_start(void *arg1, void *arg2)
+{
+ int fd;
+ int shm_id = (intptr_t)arg1;
+
+ if (g_unaffinitize_thread) {
+ spdk_unaffinitize_thread();
+ }
+
+ snprintf(g_path, sizeof(g_path), "/var/run/spdk_bdev%d", shm_id);
+ fd = open(g_path, O_CREAT | O_EXCL | O_RDWR, S_IFREG);
+ if (fd < 0) {
+ fprintf(stderr, "could not create sentinel file %s\n", g_path);
+ exit(1);
+ }
+ close(fd);
+}
+
+static void
+bdev_svc_shutdown(void)
+{
+ unlink(g_path);
+ spdk_app_stop(0);
+}
+
+int
+main(int argc, char **argv)
+{
+ int rc;
+ struct spdk_app_opts opts = {};
+
+ /* default value in opts structure */
+ spdk_app_opts_init(&opts);
+
+ opts.name = "bdev_svc";
+ opts.shutdown_cb = bdev_svc_shutdown;
+ opts.max_delay_us = 1000 * 1000;
+
+ if ((rc = spdk_app_parse_args(argc, argv, &opts, "", NULL,
+ bdev_svc_parse_arg, bdev_svc_usage)) !=
+ SPDK_APP_PARSE_ARGS_SUCCESS) {
+ exit(rc);
+ }
+
+ /* User did not specify a reactor mask. Test scripts may do this when using
+ * bdev_svc as a primary process to speed up nvme test programs by running
+ * them as secondary processes. In that case, we will unaffinitize the thread
+ * in the bdev_svc_start routine, which will allow the scheduler to move this
+ * thread so it doesn't conflict with pinned threads in the secondary processes.
+ */
+ if (opts.reactor_mask == NULL) {
+ g_unaffinitize_thread = true;
+ }
+
+ rc = spdk_app_start(&opts, bdev_svc_start, (void *)(intptr_t)opts.shm_id, NULL);
+
+ spdk_app_fini();
+
+ return rc;
+}
diff --git a/src/spdk/test/app/histogram_perf/.gitignore b/src/spdk/test/app/histogram_perf/.gitignore
new file mode 100644
index 00000000..c77b0531
--- /dev/null
+++ b/src/spdk/test/app/histogram_perf/.gitignore
@@ -0,0 +1 @@
+histogram_perf
diff --git a/src/spdk/test/app/histogram_perf/Makefile b/src/spdk/test/app/histogram_perf/Makefile
new file mode 100644
index 00000000..7c6ecd89
--- /dev/null
+++ b/src/spdk/test/app/histogram_perf/Makefile
@@ -0,0 +1,55 @@
+#
+# BSD LICENSE
+#
+# Copyright (c) Intel Corporation.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of Intel Corporation nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+SPDK_ROOT_DIR := $(abspath $(CURDIR)/../../..)
+include $(SPDK_ROOT_DIR)/mk/spdk.common.mk
+include $(SPDK_ROOT_DIR)/mk/spdk.app.mk
+
+APP = histogram_perf
+
+C_SRCS = histogram_perf.c
+
+SPDK_LIB_LIST = thread util log
+
+LIBS += $(SPDK_LIB_LINKER_ARGS) $(ENV_LINKER_ARGS)
+
+all: $(APP)
+ @:
+
+$(APP): $(OBJS) $(SPDK_LIB_FILES)
+ $(LINK_C)
+
+clean:
+ $(CLEAN_C) $(APP)
+
+include $(SPDK_ROOT_DIR)/mk/spdk.deps.mk
diff --git a/src/spdk/test/app/histogram_perf/histogram_perf.c b/src/spdk/test/app/histogram_perf/histogram_perf.c
new file mode 100644
index 00000000..5d9de527
--- /dev/null
+++ b/src/spdk/test/app/histogram_perf/histogram_perf.c
@@ -0,0 +1,102 @@
+/*-
+ * BSD LICENSE
+ *
+ * Copyright (c) Intel Corporation.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * * Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * * Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in
+ * the documentation and/or other materials provided with the
+ * distribution.
+ * * Neither the name of Intel Corporation nor the names of its
+ * contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+ * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ * OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+ * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#include "spdk/stdinc.h"
+
+#include "spdk/env.h"
+#include "spdk/util.h"
+#include "spdk/histogram_data.h"
+
+/*
+ * This applications is a simple test app used to test the performance of
+ * tallying datapoints with struct spdk_histogram_data. It can be used
+ * to measure the effect of changes to the spdk_histogram_data implementation.
+ *
+ * There are no command line parameters currently - it just tallies
+ * datapoints for 10 seconds in a default-sized histogram structure and
+ * then prints out the number of tallies performed.
+ */
+
+static void
+usage(const char *prog)
+{
+ printf("usage: %s\n", prog);
+ printf("Options:\n");
+}
+
+int
+main(int argc, char **argv)
+{
+ struct spdk_histogram_data *h;
+ struct spdk_env_opts opts;
+ uint64_t tsc[128], t, end_tsc, count;
+ uint32_t i;
+ int ch;
+ int rc = 0;
+
+ while ((ch = getopt(argc, argv, "")) != -1) {
+ switch (ch) {
+ default:
+ usage(argv[0]);
+ return 1;
+ }
+ }
+
+ spdk_env_opts_init(&opts);
+ if (spdk_env_init(&opts)) {
+ printf("Err: Unable to initialize SPDK env\n");
+ return 1;
+ }
+
+ for (i = 0; i < SPDK_COUNTOF(tsc); i++) {
+ tsc[i] = spdk_get_ticks();
+ }
+
+ end_tsc = spdk_get_ticks() + (10 * spdk_get_ticks_hz());
+ count = 0;
+ h = spdk_histogram_data_alloc();
+
+ while (true) {
+ t = spdk_get_ticks();
+ spdk_histogram_data_tally(h, t - tsc[count % 128]);
+ count++;
+ if (t > end_tsc) {
+ break;
+ }
+ }
+
+ printf("count = %ju\n", count);
+ spdk_histogram_data_free(h);
+
+ return rc;
+}
diff --git a/src/spdk/test/app/jsoncat/.gitignore b/src/spdk/test/app/jsoncat/.gitignore
new file mode 100644
index 00000000..3e6db4f0
--- /dev/null
+++ b/src/spdk/test/app/jsoncat/.gitignore
@@ -0,0 +1 @@
+jsoncat
diff --git a/src/spdk/test/app/jsoncat/Makefile b/src/spdk/test/app/jsoncat/Makefile
new file mode 100644
index 00000000..2bbba95b
--- /dev/null
+++ b/src/spdk/test/app/jsoncat/Makefile
@@ -0,0 +1,55 @@
+#
+# BSD LICENSE
+#
+# Copyright (c) Intel Corporation.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of Intel Corporation nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+SPDK_ROOT_DIR := $(abspath $(CURDIR)/../../..)
+include $(SPDK_ROOT_DIR)/mk/spdk.common.mk
+include $(SPDK_ROOT_DIR)/mk/spdk.app.mk
+
+APP = jsoncat
+
+C_SRCS = jsoncat.c
+
+SPDK_LIB_LIST = json thread util log
+
+LIBS += $(SPDK_LIB_LINKER_ARGS) $(ENV_LINKER_ARGS)
+
+all: $(APP)
+ @:
+
+$(APP): $(OBJS) $(SPDK_LIB_FILES)
+ $(LINK_C)
+
+clean:
+ $(CLEAN_C) $(APP)
+
+include $(SPDK_ROOT_DIR)/mk/spdk.deps.mk
diff --git a/src/spdk/test/app/jsoncat/jsoncat.c b/src/spdk/test/app/jsoncat/jsoncat.c
new file mode 100644
index 00000000..9984e32b
--- /dev/null
+++ b/src/spdk/test/app/jsoncat/jsoncat.c
@@ -0,0 +1,229 @@
+/*-
+ * BSD LICENSE
+ *
+ * Copyright (c) Intel Corporation.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * * Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * * Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in
+ * the documentation and/or other materials provided with the
+ * distribution.
+ * * Neither the name of Intel Corporation nor the names of its
+ * contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+ * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ * OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+ * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+/* Simple JSON "cat" utility */
+
+#include "spdk/stdinc.h"
+
+#include "spdk/json.h"
+
+static void
+usage(const char *prog)
+{
+ printf("usage: %s [-c] [-f] file.json\n", prog);
+ printf("Options:\n");
+ printf("-c\tallow comments in input (non-standard)\n");
+ printf("-f\tformatted output (default: compact output)\n");
+}
+
+static void
+print_json_error(FILE *pf, int rc, const char *filename)
+{
+ switch (rc) {
+ case SPDK_JSON_PARSE_INVALID:
+ fprintf(pf, "%s: invalid JSON\n", filename);
+ break;
+ case SPDK_JSON_PARSE_INCOMPLETE:
+ fprintf(pf, "%s: incomplete JSON\n", filename);
+ break;
+ case SPDK_JSON_PARSE_MAX_DEPTH_EXCEEDED:
+ fprintf(pf, "%s: maximum nesting depth exceeded\n", filename);
+ break;
+ default:
+ fprintf(pf, "%s: unknown JSON parse error\n", filename);
+ break;
+ }
+}
+
+static int
+json_write_cb(void *cb_ctx, const void *data, size_t size)
+{
+ FILE *f = cb_ctx;
+ size_t rc;
+
+ rc = fwrite(data, 1, size, f);
+ return rc == size ? 0 : -1;
+}
+
+static void *
+read_file(FILE *f, size_t *psize)
+{
+ void *buf, *newbuf;
+ size_t cur_size, buf_size, rc;
+
+ buf = NULL;
+ cur_size = 0;
+ buf_size = 128 * 1024;
+
+ while (buf_size <= 1024 * 1024 * 1024) {
+ newbuf = realloc(buf, buf_size);
+ if (newbuf == NULL) {
+ free(buf);
+ return NULL;
+ }
+ buf = newbuf;
+
+ rc = fread(buf + cur_size, 1, buf_size - cur_size, f);
+ cur_size += rc;
+
+ if (feof(f)) {
+ *psize = cur_size;
+ return buf;
+ }
+
+ if (ferror(f)) {
+ free(buf);
+ return NULL;
+ }
+
+ buf_size *= 2;
+ }
+
+ free(buf);
+ return NULL;
+}
+
+static int
+process_file(const char *filename, FILE *f, uint32_t parse_flags, uint32_t write_flags)
+{
+ size_t size;
+ void *buf, *end;
+ ssize_t rc;
+ struct spdk_json_val *values;
+ size_t num_values;
+ struct spdk_json_write_ctx *w;
+
+ buf = read_file(f, &size);
+ if (buf == NULL) {
+ fprintf(stderr, "%s: file read error\n", filename);
+ return 1;
+ }
+
+ rc = spdk_json_parse(buf, size, NULL, 0, NULL, parse_flags);
+ if (rc <= 0) {
+ print_json_error(stderr, rc, filename);
+ free(buf);
+ return 1;
+ }
+
+ num_values = (size_t)rc;
+ values = calloc(num_values, sizeof(*values));
+ if (values == NULL) {
+ perror("values calloc");
+ free(buf);
+ return 1;
+ }
+
+ rc = spdk_json_parse(buf, size, values, num_values, &end,
+ parse_flags | SPDK_JSON_PARSE_FLAG_DECODE_IN_PLACE);
+ if (rc <= 0) {
+ print_json_error(stderr, rc, filename);
+ free(values);
+ free(buf);
+ return 1;
+ }
+
+ w = spdk_json_write_begin(json_write_cb, stdout, write_flags);
+ if (w == NULL) {
+ fprintf(stderr, "json_write_begin failed\n");
+ free(values);
+ free(buf);
+ return 1;
+ }
+
+ spdk_json_write_val(w, values);
+ spdk_json_write_end(w);
+ printf("\n");
+
+ if (end != buf + size) {
+ fprintf(stderr, "%s: garbage at end of file\n", filename);
+ free(values);
+ free(buf);
+ return 1;
+ }
+
+ free(values);
+ free(buf);
+ return 0;
+}
+
+int
+main(int argc, char **argv)
+{
+ FILE *f;
+ int ch;
+ int rc;
+ uint32_t parse_flags = 0, write_flags = 0;
+ const char *filename;
+
+ while ((ch = getopt(argc, argv, "cf")) != -1) {
+ switch (ch) {
+ case 'c':
+ parse_flags |= SPDK_JSON_PARSE_FLAG_ALLOW_COMMENTS;
+ break;
+ case 'f':
+ write_flags |= SPDK_JSON_WRITE_FLAG_FORMATTED;
+ break;
+ default:
+ usage(argv[0]);
+ return 1;
+ }
+ }
+
+ if (optind == argc) {
+ filename = "-";
+ } else if (optind == argc - 1) {
+ filename = argv[optind];
+ } else {
+ usage(argv[0]);
+ return 1;
+ }
+
+ if (strcmp(filename, "-") == 0) {
+ f = stdin;
+ } else {
+ f = fopen(filename, "r");
+ if (f == NULL) {
+ perror("fopen");
+ return 1;
+ }
+ }
+
+ rc = process_file(filename, f, parse_flags, write_flags);
+
+ if (f != stdin) {
+ fclose(f);
+ }
+
+ return rc;
+}
diff --git a/src/spdk/test/app/match/match b/src/spdk/test/app/match/match
new file mode 100755
index 00000000..7c1cdc45
--- /dev/null
+++ b/src/spdk/test/app/match/match
@@ -0,0 +1,326 @@
+#!/usr/bin/env perl
+#
+# Copyright 2014-2017, Intel Corporation
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+#
+# * Neither the name of the copyright holder nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+#
+# match -- compare an output file with expected results
+#
+# usage: match [-adoqv] [match-file]...
+#
+# this script compares the output from a test run, stored in a file, with
+# the expected output. comparison is done line-by-line until either all
+# lines compare correctly (exit code 0) or a miscompare is found (exit
+# code nonzero).
+#
+# expected output is stored in a ".match" file, which contains a copy of
+# the expected output with embedded tokens for things that should not be
+# exact matches. the supported tokens are:
+#
+# $(N) an integer (i.e. one or more decimal digits)
+# $(NC) one or more decimal digits with comma separators
+# $(FP) a floating point number
+# $(S) ascii string
+# $(X) hex number
+# $(XX) hex number prefixed with 0x
+# $(W) whitespace
+# $(nW) non-whitespace
+# $(*) any string
+# $(DD) output of a "dd" run
+# $(OPT) line is optional (may be missing, matched if found)
+# $(OPX) ends a contiguous list of $(OPT)...$(OPX) lines, at least
+# one of which must match
+#
+# Additionally, if any "X.ignore" file exists, strings or phrases found per
+# line in the file will be ignored if found as a substring in the
+# corresponding output file (making it easy to skip entire output lines).
+#
+# arguments are:
+#
+# -a find all files of the form "X.match" in the current
+# directory and match them again the corresponding file "X".
+#
+# -o custom output filename - only one match file can be given
+#
+# -d debug -- show lots of debug output
+#
+# -q don't print log files on mismatch
+#
+# -v verbose -- show every line as it is being matched
+#
+
+use strict;
+use Getopt::Std;
+use Encode;
+use v5.16;
+
+select STDERR;
+binmode(STDOUT, ":utf8");
+binmode(STDERR, ":utf8");
+
+my $Me = $0;
+$Me =~ s,.*/,,;
+
+our ($opt_a, $opt_d, $opt_q, $opt_v, $opt_o);
+
+$SIG{HUP} = $SIG{INT} = $SIG{TERM} = $SIG{__DIE__} = sub {
+ die @_ if $^S;
+ my $errstr = shift;
+ die "FAIL: $Me: $errstr";
+};
+
+sub usage {
+ my $msg = shift;
+
+ warn "$Me: $msg\n" if $msg;
+ warn "Usage: $Me [-adqv] [match-file]...\n";
+ warn " or: $Me [-dqv] -o output-file match-file...\n";
+ exit 1;
+}
+
+getopts('adoqv') or usage;
+
+my %match2file;
+
+if ($opt_a) {
+ usage("-a and filename arguments are mutually exclusive")
+ if $#ARGV != -1;
+ opendir(DIR, '.') or die "opendir: .: $!\n";
+ my @matchfiles = grep { /(.*)\.match$/ && -f $1 } readdir(DIR);
+ closedir(DIR);
+ die "no files found to process\n" unless @matchfiles;
+ foreach my $mfile (@matchfiles) {
+ die "$mfile: $!\n" unless open(F, $mfile);
+ close(F);
+ my $ofile = $mfile;
+ $ofile =~ s/\.match$//;
+ die "$mfile found but cannot open $ofile: $!\n"
+ unless open(F, $ofile);
+ close(F);
+ $match2file{$mfile} = $ofile;
+ }
+} elsif ($opt_o) {
+ usage("-o argument requires two paths") if $#ARGV != 1;
+
+ $match2file{$ARGV[1]} = $ARGV[0];
+} else {
+ usage("no match-file arguments found") if $#ARGV == -1;
+
+ # to improve the failure case, check all filename args exist and
+ # are provided in pairs now, before going through and processing them
+ foreach my $mfile (@ARGV) {
+ my $ofile = $mfile;
+ usage("$mfile: not a .match file") unless
+ $ofile =~ s/\.match$//;
+ usage("$mfile: $!") unless open(F, $mfile);
+ close(F);
+ usage("$ofile: $!") unless open(F, $ofile);
+ close(F);
+ $match2file{$mfile} = $ofile;
+ }
+}
+
+my $mfile;
+my $ofile;
+my $ifile;
+print "Files to be processed:\n" if $opt_v;
+foreach $mfile (sort keys %match2file) {
+ $ofile = $match2file{$mfile};
+ $ifile = $ofile . ".ignore";
+ $ifile = undef unless (-f $ifile);
+ if ($opt_v) {
+ print " match-file \"$mfile\" output-file \"$ofile\"";
+ if ($ifile) {
+ print " ignore-file $ifile\n";
+ } else {
+ print "\n";
+ }
+ }
+ match($mfile, $ofile, $ifile);
+}
+
+exit 0;
+
+#
+# strip_it - user can optionally ignore lines from files that contain
+# any number of substrings listed in a file called "X.ignore" where X
+# is the name of the output file.
+#
+sub strip_it {
+ my ($ifile, $file, $input) = @_;
+ # if there is no ignore file just return unaltered input
+ return $input unless $ifile;
+ my @lines_in = split /^/, $input;
+ my $output;
+ my $line_in;
+ my @i_file = split /^/, snarf($ifile);
+ my $i_line;
+ my $ignore_it = 0;
+
+ foreach $line_in (@lines_in) {
+ my @i_lines = @i_file;
+ foreach $i_line (@i_lines) {
+ chop($i_line);
+ if (index($line_in, $i_line) != -1) {
+ $ignore_it = 1;
+ if ($opt_v) {
+ print "Ignoring (from $file): $line_in";
+ }
+ }
+ }
+ if ($ignore_it == 0) {
+ $output .= $line_in;
+ }
+ $ignore_it = 0;
+ }
+ return $output;
+}
+
+#
+# match -- process a match-file, output-file pair
+#
+sub match {
+ my ($mfile, $ofile, $ifile) = @_;
+ my $pat;
+ my $output = snarf($ofile);
+ $output = strip_it($ifile, $ofile, $output);
+ my $all_lines = $output;
+ my $line_pat = 0;
+ my $line_out = 0;
+ my $opt = 0;
+ my $opx = 0;
+ my $opt_found = 0;
+ my $fstr = snarf($mfile);
+ $fstr = strip_it($ifile, $mfile, $fstr);
+ for (split /^/, $fstr) {
+ $pat = $_;
+ $line_pat++;
+ $line_out++;
+ s/([*+?|{}.\\^\$\[()])/\\$1/g;
+ s/\\\$\\\(FP\\\)/[-+]?\\d*\\.?\\d+([eE][-+]?\\d+)?/g;
+ s/\\\$\\\(N\\\)/[-+]?\\d+/g;
+ s/\\\$\\\(NC\\\)/[-+]?\\d+(,[0-9]+)*/g;
+ s/\\\$\\\(\\\*\\\)/\\p{Print}*/g;
+ s/\\\$\\\(S\\\)/\\P{IsC}+/g;
+ s/\\\$\\\(X\\\)/\\p{XPosixXDigit}+/g;
+ s/\\\$\\\(XX\\\)/0x\\p{XPosixXDigit}+/g;
+ s/\\\$\\\(W\\\)/\\p{Blank}*/g;
+ s/\\\$\\\(nW\\\)/\\p{Graph}*/g;
+ s/\\\$\\\(DD\\\)/\\d+\\+\\d+ records in\n\\d+\\+\\d+ records out\n\\d+ bytes \\\(\\d+ .B\\\) copied, [.0-9e-]+[^,]*, [.0-9]+ .B.s/g;
+ if (s/\\\$\\\(OPT\\\)//) {
+ $opt = 1;
+ } elsif (s/\\\$\\\(OPX\\\)//) {
+ $opx = 1;
+ } else {
+ $opt_found = 0;
+ }
+
+ if ($opt_v) {
+ my @lines = split /\n/, $output;
+ my $line;
+ if (@lines) {
+ $line = $lines[0];
+ } else {
+ $line = "[EOF]";
+ }
+
+ printf("%s:%-3d %s%s:%-3d %s\n", $mfile, $line_pat, $pat, $ofile, $line_out, $line);
+ }
+
+ print " => /$_/\n" if $opt_d;
+ print " [$output]\n" if $opt_d;
+ unless ($output =~ s/^$_//) {
+ if ($opt || ($opx && $opt_found)) {
+ printf("%s:%-3d [skipping optional line]\n", $ofile, $line_out) if $opt_v;
+ $line_out--;
+ $opt = 0;
+ } else {
+ if (!$opt_v) {
+ if ($opt_q) {
+ print "[MATCHING FAILED]\n";
+ } else {
+ print "[MATCHING FAILED, COMPLETE FILE ($ofile) BELOW]\n$all_lines\n[EOF]\n";
+ }
+ $opt_v = 1;
+ match($mfile, $ofile);
+ }
+
+ die "$mfile:$line_pat did not match pattern\n";
+ }
+ } elsif ($opt) {
+ $opt_found = 1;
+ }
+ $opx = 0;
+ }
+
+ if ($output ne '') {
+ if (!$opt_v) {
+ if ($opt_q) {
+ print "[MATCHING FAILED]\n";
+ } else {
+ print "[MATCHING FAILED, COMPLETE FILE ($ofile) BELOW]\n$all_lines\n[EOF]\n";
+ }
+ }
+
+ # make it a little more print-friendly...
+ $output =~ s/\n/\\n/g;
+ die "line $line_pat: unexpected output: \"$output\"\n";
+ }
+}
+
+
+#
+# snarf -- slurp an entire file into memory
+#
+sub snarf {
+ my ($file) = @_;
+ my $fh;
+ open($fh, '<', $file) or die "$file $!\n";
+
+ local $/;
+ $_ = <$fh>;
+ close $fh;
+
+ # check known encodings or die
+ my $decoded;
+ my @encodings = ("UTF-8", "UTF-16", "UTF-16LE", "UTF-16BE");
+
+ foreach my $enc (@encodings) {
+ eval { $decoded = decode( $enc, $_, Encode::FB_CROAK ) };
+
+ if (!$@) {
+ $decoded =~ s/\R/\n/g;
+ return $decoded;
+ }
+ }
+
+ die "$Me: ERROR: Unknown file encoding";
+}
diff --git a/src/spdk/test/app/stub/.gitignore b/src/spdk/test/app/stub/.gitignore
new file mode 100644
index 00000000..39802f64
--- /dev/null
+++ b/src/spdk/test/app/stub/.gitignore
@@ -0,0 +1 @@
+stub
diff --git a/src/spdk/test/app/stub/Makefile b/src/spdk/test/app/stub/Makefile
new file mode 100644
index 00000000..9cca6b2c
--- /dev/null
+++ b/src/spdk/test/app/stub/Makefile
@@ -0,0 +1,58 @@
+#
+# BSD LICENSE
+#
+# Copyright (c) Intel Corporation.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of Intel Corporation nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+SPDK_ROOT_DIR := $(abspath $(CURDIR)/../../..)
+include $(SPDK_ROOT_DIR)/mk/spdk.common.mk
+include $(SPDK_ROOT_DIR)/mk/spdk.app.mk
+include $(SPDK_ROOT_DIR)/mk/spdk.modules.mk
+
+APP = stub
+
+C_SRCS := stub.c
+
+SPDK_LIB_LIST = event conf nvme log trace rpc jsonrpc json thread util
+
+LIBS += $(SOCK_MODULES_LINKER_ARGS)
+LIBS += $(SPDK_LIB_LINKER_ARGS)
+LIBS += $(ENV_LINKER_ARGS)
+
+all : $(APP)
+ @:
+
+$(APP) : $(OBJS) $(SOCK_MODULES_FILES) $(SPDK_LIB_FILES) $(ENV_LIBS)
+ $(LINK_C)
+
+clean :
+ $(CLEAN_C) $(APP)
+
+include $(SPDK_ROOT_DIR)/mk/spdk.deps.mk
diff --git a/src/spdk/test/app/stub/stub.c b/src/spdk/test/app/stub/stub.c
new file mode 100644
index 00000000..c52917dd
--- /dev/null
+++ b/src/spdk/test/app/stub/stub.c
@@ -0,0 +1,147 @@
+/*-
+ * BSD LICENSE
+ *
+ * Copyright (c) Intel Corporation.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * * Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * * Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in
+ * the documentation and/or other materials provided with the
+ * distribution.
+ * * Neither the name of Intel Corporation nor the names of its
+ * contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+ * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ * OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+ * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#include "spdk/stdinc.h"
+
+#include "spdk/event.h"
+#include "spdk/nvme.h"
+
+static char g_path[256];
+
+static void
+usage(char *executable_name)
+{
+ printf("%s [options]\n", executable_name);
+ printf("options:\n");
+ printf(" -i shared memory ID [required]\n");
+ printf(" -m mask core mask for DPDK\n");
+ printf(" -n channel number of memory channels used for DPDK\n");
+ printf(" -p core master (primary) core for DPDK\n");
+ printf(" -s size memory size in MB for DPDK\n");
+ printf(" -H show this usage\n");
+}
+
+static bool
+probe_cb(void *cb_ctx, const struct spdk_nvme_transport_id *trid,
+ struct spdk_nvme_ctrlr_opts *opts)
+{
+ /*
+ * Set the io_queue_size to UINT16_MAX to initialize
+ * the controller with the possible largest queue size.
+ */
+ opts->io_queue_size = UINT16_MAX;
+ return true;
+}
+
+static void
+attach_cb(void *cb_ctx, const struct spdk_nvme_transport_id *trid,
+ struct spdk_nvme_ctrlr *ctrlr, const struct spdk_nvme_ctrlr_opts *opts)
+{
+}
+
+static void
+stub_start(void *arg1, void *arg2)
+{
+ int shm_id = (intptr_t)arg1;
+
+ spdk_unaffinitize_thread();
+
+ if (spdk_nvme_probe(NULL, NULL, probe_cb, attach_cb, NULL) != 0) {
+ fprintf(stderr, "spdk_nvme_probe() failed\n");
+ exit(1);
+ }
+
+ snprintf(g_path, sizeof(g_path), "/var/run/spdk_stub%d", shm_id);
+ if (mknod(g_path, S_IFREG, 0) != 0) {
+ fprintf(stderr, "could not create sentinel file %s\n", g_path);
+ exit(1);
+ }
+}
+
+static void
+stub_shutdown(void)
+{
+ unlink(g_path);
+ spdk_app_stop(0);
+}
+
+int
+main(int argc, char **argv)
+{
+ int ch;
+ struct spdk_app_opts opts = {};
+
+ /* default value in opts structure */
+ spdk_app_opts_init(&opts);
+
+ opts.name = "stub";
+ opts.rpc_addr = NULL;
+
+ while ((ch = getopt(argc, argv, "i:m:n:p:s:H")) != -1) {
+ switch (ch) {
+ case 'i':
+ opts.shm_id = atoi(optarg);
+ break;
+ case 'm':
+ opts.reactor_mask = optarg;
+ break;
+ case 'n':
+ opts.mem_channel = atoi(optarg);
+ break;
+ case 'p':
+ opts.master_core = atoi(optarg);
+ break;
+ case 's':
+ opts.mem_size = atoi(optarg);
+ break;
+ case 'H':
+ default:
+ usage(argv[0]);
+ exit(EXIT_SUCCESS);
+ }
+ }
+
+ if (opts.shm_id < 0) {
+ fprintf(stderr, "%s: -i shared memory ID must be specified\n", argv[0]);
+ usage(argv[0]);
+ exit(1);
+ }
+
+ opts.shutdown_cb = stub_shutdown;
+ opts.max_delay_us = 1000 * 1000;
+
+ ch = spdk_app_start(&opts, stub_start, (void *)(intptr_t)opts.shm_id, NULL);
+ spdk_app_fini();
+
+ return ch;
+}