summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 17:46:04 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 17:46:04 +0000
commit688bab52c0ebb357edf4ebe6f388c930cb16415d (patch)
treed59dd8cd7d33fa9d6388c1e0f27bdb9fc717455d /debian
parentUpdating vcs fields. (diff)
downloadcryptsetup-688bab52c0ebb357edf4ebe6f388c930cb16415d.tar.xz
cryptsetup-688bab52c0ebb357edf4ebe6f388c930cb16415d.zip
Using decrypt_keyctl by default if no keyscript in /etc/crypttab to cache passphrase for multiple filesystems.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--debian/control3
-rw-r--r--debian/functions5
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index a78c2d5..a67d0e7 100644
--- a/debian/control
+++ b/debian/control
@@ -44,9 +44,10 @@ Architecture: linux-any
Multi-Arch: foreign
Depends: cryptsetup-bin (>= 2:1.6.0),
dmsetup,
+ keyutils,
${misc:Depends},
${shlibs:Depends}
-Suggests: dosfstools, keyutils, liblocale-gettext-perl
+Suggests: dosfstools, liblocale-gettext-perl
Replaces: cryptsetup-run (<< 2:2.1.0-6)
Recommends: cryptsetup-initramfs, cryptsetup-run
Breaks: cryptsetup-run (<< 2:2.1.0-6)
diff --git a/debian/functions b/debian/functions
index 9bd1ac8..0c76eb1 100644
--- a/debian/functions
+++ b/debian/functions
@@ -107,6 +107,11 @@ crypttab_parse_options() {
done
IFS=" "
+ # use decrypt_keyctl by default if no keyscript in /etc/crypttab
+ if [ -z "$CRYPTTAB_OPTION_keyscript" ]; then
+ CRYPTTAB_OPTION_keyscript="/lib/cryptsetup/scripts/decrypt_keyctl"
+ fi
+
if ! _get_crypt_type; then # set CRYPTTAB_TYPE to the type of crypt device
CRYPTTAB_TYPE="plain"
if [ "$quiet" = "n" ]; then