summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:34:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:34:10 +0000
commit0b2a2f19877b196e9638f373b4676c78b00ae8a2 (patch)
tree35ff578376d4184811f217988c49a52b5fe5acbe /Makefile
parentInitial commit. (diff)
downloaddebootstrap-7a525095d95d0ee5698a0dab05183f2b90284417.tar.xz
debootstrap-7a525095d95d0ee5698a0dab05183f2b90284417.zip
Adding upstream version 1.0.123+deb11u2.upstream/1.0.123+deb11u2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..8516803
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,18 @@
+# avoid dpkg-dev dependency; fish out the version with sed
+VERSION := $(shell sed 's/.*(\(.*\)).*/\1/; q' debian/changelog)
+
+all:
+
+clean:
+
+DSDIR=$(DESTDIR)/usr/share/debootstrap
+install:
+ mkdir -p $(DSDIR)/scripts
+ mkdir -p $(DESTDIR)/usr/sbin
+
+ cp -a scripts/* $(DSDIR)/scripts/
+ install -o root -g root -m 0644 functions $(DSDIR)/
+
+ sed 's/@VERSION@/$(VERSION)/g' debootstrap >$(DESTDIR)/usr/sbin/debootstrap
+ chown root:root $(DESTDIR)/usr/sbin/debootstrap
+ chmod 0755 $(DESTDIR)/usr/sbin/debootstrap