summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:36:26 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:36:26 +0000
commit569106afbc36d21ec7584444df3072aefb934cac (patch)
tree7f084acdd4363d4c4ae5bdbe90d19cbaefddc5fb /debian/rules
parentAdding upstream version 2.21.3+deb11u1. (diff)
downloaddevscripts-569106afbc36d21ec7584444df3072aefb934cac.tar.xz
devscripts-569106afbc36d21ec7584444df3072aefb934cac.zip
Adding debian version 2.21.3+deb11u1.debian/2.21.3+deb11u1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e82dc4e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+UBU_SUGGESTS=debian-keyring, equivs, liblwp-protocol-https-perl, libsoap-lite-perl
+ifeq ($(shell dpkg-vendor --derives-from Ubuntu && echo ubuntu),ubuntu)
+ SUBSTVARS=-V'vendor:Suggests=$(UBU_SUGGESTS)' -V'vendor:Recommends='
+else
+ SUBSTVARS=-V'vendor:Suggests=' -V'vendor:Recommends=$(UBU_SUGGESTS)'
+endif
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@ --with python3
+
+override_dh_gencontrol:
+ dh_gencontrol -- $(SUBSTVARS) \
+ -V"devscripts:LongDesc=$$(cat README| awk '/^- annotate-output/,/^ mailing lists./'|sed -e '/^[[:space:]]*$$/d' -e 's/^/ /g')"