summaryrefslogtreecommitdiffstats
path: root/lib/compat/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
commitb86570f63e533abcbcb97c2572e0e5732a96307b (patch)
treecabc83be691530ae685c45a8bc7620ccc0e1ebdf /lib/compat/Makefile.am
parentInitial commit. (diff)
downloaddpkg-upstream/1.20.13.tar.xz
dpkg-upstream/1.20.13.zip
Adding upstream version 1.20.13.upstream/1.20.13upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'lib/compat/Makefile.am')
-rw-r--r--lib/compat/Makefile.am101
1 files changed, 101 insertions, 0 deletions
diff --git a/lib/compat/Makefile.am b/lib/compat/Makefile.am
new file mode 100644
index 0000000..4477c27
--- /dev/null
+++ b/lib/compat/Makefile.am
@@ -0,0 +1,101 @@
+## Process this file with automake to produce Makefile.in
+
+AM_CPPFLAGS = \
+ -idirafter $(top_srcdir)/lib/compat \
+ -I$(top_builddir)
+
+
+noinst_LTLIBRARIES = libcompat-test.la libcompat.la
+
+libcompat_test_la_CPPFLAGS = $(AM_CPPFLAGS) -DTEST_LIBCOMPAT=1
+libcompat_test_la_SOURCES = \
+ compat.h \
+ md5.c md5.h \
+ strchrnul.c \
+ strnlen.c \
+ strndup.c \
+ strsignal.c \
+ snprintf.c vsnprintf.c \
+ asprintf.c vasprintf.c \
+ alphasort.c \
+ scandir.c \
+ unsetenv.c
+
+if HAVE_SYS_ERRLIST
+libcompat_test_la_SOURCES += strerror.c
+endif
+
+if WITH_LIBSELINUX
+libcompat_test_la_SOURCES += selinux.c
+endif
+
+libcompat_la_SOURCES = \
+ empty.c \
+ compat.h \
+ gettext.h
+
+if !HAVE_LIBMD_MD5
+libcompat_la_SOURCES += md5.c md5.h
+endif
+
+if !HAVE_GETOPT
+libcompat_la_SOURCES += getopt.c getopt.h
+else
+if !HAVE_GETOPT_LONG
+libcompat_la_SOURCES += getopt.c getopt.h
+endif
+endif
+
+if !HAVE_GETOPT_LONG
+libcompat_la_SOURCES += getopt1.c
+endif
+
+if !HAVE_OBSTACK_FREE
+libcompat_la_SOURCES += obstack.c obstack.h
+endif
+
+if !HAVE_STRNLEN
+libcompat_la_SOURCES += strnlen.c
+endif
+
+if !HAVE_STRCHRNUL
+libcompat_la_SOURCES += strchrnul.c
+endif
+
+if !HAVE_STRNDUP
+libcompat_la_SOURCES += strndup.c
+endif
+
+if !HAVE_STRERROR
+libcompat_la_SOURCES += strerror.c
+endif
+
+if !HAVE_STRSIGNAL
+libcompat_la_SOURCES += strsignal.c
+endif
+
+if WITH_LIBSELINUX
+if !HAVE_SETEXECFILECON
+libcompat_la_SOURCES += selinux.c
+endif
+endif
+
+if !HAVE_C99_SNPRINTF
+libcompat_la_SOURCES += snprintf.c vsnprintf.c
+endif
+
+if !HAVE_ASPRINTF
+libcompat_la_SOURCES += asprintf.c vasprintf.c
+endif
+
+if !HAVE_ALPHASORT
+libcompat_la_SOURCES += alphasort.c
+endif
+
+if !HAVE_SCANDIR
+libcompat_la_SOURCES += scandir.c
+endif
+
+if !HAVE_UNSETENV
+libcompat_la_SOURCES += unsetenv.c
+endif