summaryrefslogtreecommitdiffstats
path: root/tests/t-breaks/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
commitb86570f63e533abcbcb97c2572e0e5732a96307b (patch)
treecabc83be691530ae685c45a8bc7620ccc0e1ebdf /tests/t-breaks/Makefile
parentInitial commit. (diff)
downloaddpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.tar.xz
dpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.zip
Adding upstream version 1.20.13.upstream/1.20.13upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-breaks/Makefile')
-rw-r--r--tests/t-breaks/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/t-breaks/Makefile b/tests/t-breaks/Makefile
new file mode 100644
index 0000000..9ffd02c
--- /dev/null
+++ b/tests/t-breaks/Makefile
@@ -0,0 +1,12 @@
+TESTS_DEB := lib-a-0 lib-a-1 lib-b-0 lib-b-1 pkg-c
+
+include ../Test.mk
+
+DPKG_OPTIONS += --auto-deconfigure
+
+test-case:
+ $(DPKG_INSTALL) lib-a-0.deb lib-b-0.deb
+ $(DPKG_INSTALL) pkg-c.deb lib-a-1.deb lib-b-1.deb
+
+test-clean:
+ $(DPKG_PURGE) lib-a lib-b pkg-c