summaryrefslogtreecommitdiffstats
path: root/tests/t-conffile-forceask
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
commitb86570f63e533abcbcb97c2572e0e5732a96307b (patch)
treecabc83be691530ae685c45a8bc7620ccc0e1ebdf /tests/t-conffile-forceask
parentInitial commit. (diff)
downloaddpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.tar.xz
dpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.zip
Adding upstream version 1.20.13.upstream/1.20.13upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-conffile-forceask')
-rw-r--r--tests/t-conffile-forceask/Makefile16
-rw-r--r--tests/t-conffile-forceask/mod-conffile1
-rw-r--r--tests/t-conffile-forceask/pkg-conff-forceask-0/DEBIAN/conffiles1
-rw-r--r--tests/t-conffile-forceask/pkg-conff-forceask-0/DEBIAN/control9
-rw-r--r--tests/t-conffile-forceask/pkg-conff-forceask-0/test-conffile1
-rw-r--r--tests/t-conffile-forceask/pkg-conff-forceask-1/DEBIAN/conffiles1
-rw-r--r--tests/t-conffile-forceask/pkg-conff-forceask-1/DEBIAN/control9
-rw-r--r--tests/t-conffile-forceask/pkg-conff-forceask-1/test-conffile1
-rw-r--r--tests/t-conffile-forceask/ref-conffile1
9 files changed, 40 insertions, 0 deletions
diff --git a/tests/t-conffile-forceask/Makefile b/tests/t-conffile-forceask/Makefile
new file mode 100644
index 0000000..c40e2fe
--- /dev/null
+++ b/tests/t-conffile-forceask/Makefile
@@ -0,0 +1,16 @@
+TESTS_DEB := pkg-conff-forceask-0 pkg-conff-forceask-1
+
+include ../Test.mk
+
+test-case:
+
+ # Test that we get the new conffile after a modified one.
+ $(DPKG_INSTALL) pkg-conff-forceask-0.deb
+ $(BEROOT) cp mod-conffile "$(DPKG_INSTDIR)/test-conffile"
+ $(DPKG_INSTALL) --force-confask --force-confnew pkg-conff-forceask-1.deb
+ cmp mod-conffile "$(DPKG_INSTDIR)/test-conffile.dpkg-old"
+ cmp ref-conffile "$(DPKG_INSTDIR)/test-conffile"
+ $(DPKG_PURGE) pkg-conff-forceask
+
+test-clean:
+ $(DPKG_PURGE) pkg-conff-forceask
diff --git a/tests/t-conffile-forceask/mod-conffile b/tests/t-conffile-forceask/mod-conffile
new file mode 100644
index 0000000..73f8903
--- /dev/null
+++ b/tests/t-conffile-forceask/mod-conffile
@@ -0,0 +1 @@
+test modified
diff --git a/tests/t-conffile-forceask/pkg-conff-forceask-0/DEBIAN/conffiles b/tests/t-conffile-forceask/pkg-conff-forceask-0/DEBIAN/conffiles
new file mode 100644
index 0000000..4fad7e9
--- /dev/null
+++ b/tests/t-conffile-forceask/pkg-conff-forceask-0/DEBIAN/conffiles
@@ -0,0 +1 @@
+/test-conffile
diff --git a/tests/t-conffile-forceask/pkg-conff-forceask-0/DEBIAN/control b/tests/t-conffile-forceask/pkg-conff-forceask-0/DEBIAN/control
new file mode 100644
index 0000000..e817b0b
--- /dev/null
+++ b/tests/t-conffile-forceask/pkg-conff-forceask-0/DEBIAN/control
@@ -0,0 +1,9 @@
+Package: pkg-conff-forceask
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - force-confask behaviour
+ Debbug: ??
+
diff --git a/tests/t-conffile-forceask/pkg-conff-forceask-0/test-conffile b/tests/t-conffile-forceask/pkg-conff-forceask-0/test-conffile
new file mode 100644
index 0000000..ee5a694
--- /dev/null
+++ b/tests/t-conffile-forceask/pkg-conff-forceask-0/test-conffile
@@ -0,0 +1 @@
+test ref
diff --git a/tests/t-conffile-forceask/pkg-conff-forceask-1/DEBIAN/conffiles b/tests/t-conffile-forceask/pkg-conff-forceask-1/DEBIAN/conffiles
new file mode 100644
index 0000000..4fad7e9
--- /dev/null
+++ b/tests/t-conffile-forceask/pkg-conff-forceask-1/DEBIAN/conffiles
@@ -0,0 +1 @@
+/test-conffile
diff --git a/tests/t-conffile-forceask/pkg-conff-forceask-1/DEBIAN/control b/tests/t-conffile-forceask/pkg-conff-forceask-1/DEBIAN/control
new file mode 100644
index 0000000..be39ec8
--- /dev/null
+++ b/tests/t-conffile-forceask/pkg-conff-forceask-1/DEBIAN/control
@@ -0,0 +1,9 @@
+Package: pkg-conff-forceask
+Version: 1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - force-confask behaviour
+ Debbug: ??
+
diff --git a/tests/t-conffile-forceask/pkg-conff-forceask-1/test-conffile b/tests/t-conffile-forceask/pkg-conff-forceask-1/test-conffile
new file mode 100644
index 0000000..ee5a694
--- /dev/null
+++ b/tests/t-conffile-forceask/pkg-conff-forceask-1/test-conffile
@@ -0,0 +1 @@
+test ref
diff --git a/tests/t-conffile-forceask/ref-conffile b/tests/t-conffile-forceask/ref-conffile
new file mode 100644
index 0000000..ee5a694
--- /dev/null
+++ b/tests/t-conffile-forceask/ref-conffile
@@ -0,0 +1 @@
+test ref