summaryrefslogtreecommitdiffstats
path: root/tests/t-conffile-orphan/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
commitb86570f63e533abcbcb97c2572e0e5732a96307b (patch)
treecabc83be691530ae685c45a8bc7620ccc0e1ebdf /tests/t-conffile-orphan/Makefile
parentInitial commit. (diff)
downloaddpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.tar.xz
dpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.zip
Adding upstream version 1.20.13.upstream/1.20.13upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--tests/t-conffile-orphan/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/t-conffile-orphan/Makefile b/tests/t-conffile-orphan/Makefile
new file mode 100644
index 0000000..1f51ccb
--- /dev/null
+++ b/tests/t-conffile-orphan/Makefile
@@ -0,0 +1,14 @@
+TESTS_DEB := pkg-conff-orphan-0 pkg-conff-orphan-1 pkg-conff-takeover
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-conff-orphan-0.deb
+ $(DPKG_INSTALL) pkg-conff-orphan-1.deb
+ # test if the other package can takeover the orphan conffile
+ $(DPKG_INSTALL) pkg-conff-takeover.deb
+
+test-clean:
+ $(DPKG_PURGE) pkg-conff-orphan
+ $(DPKG_PURGE) pkg-conff-takeover
+