summaryrefslogtreecommitdiffstats
path: root/tests/t-conflict-provide-replace-interface/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
commitb86570f63e533abcbcb97c2572e0e5732a96307b (patch)
treecabc83be691530ae685c45a8bc7620ccc0e1ebdf /tests/t-conflict-provide-replace-interface/Makefile
parentInitial commit. (diff)
downloaddpkg-upstream.tar.xz
dpkg-upstream.zip
Adding upstream version 1.20.13.upstream/1.20.13upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--tests/t-conflict-provide-replace-interface/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/t-conflict-provide-replace-interface/Makefile b/tests/t-conflict-provide-replace-interface/Makefile
new file mode 100644
index 0000000..6aefafb
--- /dev/null
+++ b/tests/t-conflict-provide-replace-interface/Makefile
@@ -0,0 +1,18 @@
+TESTS_DEB := pkg-a pkg-b
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-a.deb
+ # The user was not explicit in the request, fail
+ ! $(DPKG_INSTALL) pkg-b.deb
+ # Even if requesting auto-deconfigure the request is not explicit
+ # enough, fail
+ ! $(DPKG_INSTALL) -B pkg-b.deb
+ # Set up the desired transaction
+ echo pkg-a deinstall | $(BEROOT) $(DPKG) --set-selections
+ $(DPKG_INSTALL) pkg-b.deb
+
+test-clean:
+ $(DPKG_PURGE) pkg-b
+ -$(DPKG_PURGE) pkg-a