summaryrefslogtreecommitdiffstats
path: root/tests/t-conflict-provide-replace-virtual-multiarch/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
commitb86570f63e533abcbcb97c2572e0e5732a96307b (patch)
treecabc83be691530ae685c45a8bc7620ccc0e1ebdf /tests/t-conflict-provide-replace-virtual-multiarch/Makefile
parentInitial commit. (diff)
downloaddpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.tar.xz
dpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.zip
Adding upstream version 1.20.13.upstream/1.20.13upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--tests/t-conflict-provide-replace-virtual-multiarch/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/t-conflict-provide-replace-virtual-multiarch/Makefile b/tests/t-conflict-provide-replace-virtual-multiarch/Makefile
new file mode 100644
index 0000000..22176a3
--- /dev/null
+++ b/tests/t-conflict-provide-replace-virtual-multiarch/Makefile
@@ -0,0 +1,23 @@
+TESTS_DEB := pkg-virt-i386 pkg-virt-amd64 pkg-real-i386 pkg-real-amd64
+
+include ../Test.mk
+
+test-case:
+ $(DPKG) --add-architecture amd64
+ $(DPKG) --add-architecture i386
+ $(DPKG_INSTALL) pkg-virt-i386.deb
+ # Configuring pkg-real:amd64 should not be allowed
+ ! $(DPKG_INSTALL) pkg-real-amd64.deb
+ $(DPKG_INSTALL) pkg-real-i386.deb
+ $(DPKG_INSTALL) pkg-virt-amd64.deb
+ $(DPKG_INSTALL) pkg-real-i386.deb
+ # Purging should not be allowed
+ ! $(DPKG_PURGE) pkg-virt:i386
+
+test-clean:
+ $(DPKG_PURGE) pkg-real:i386
+ $(DPKG_PURGE) pkg-real:amd64
+ $(DPKG_PURGE) pkg-virt:i386
+ $(DPKG_PURGE) pkg-virt:amd64
+ $(DPKG) --remove-architecture amd64
+ $(DPKG) --remove-architecture i386