summaryrefslogtreecommitdiffstats
path: root/tests/t-disappear/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
commitb86570f63e533abcbcb97c2572e0e5732a96307b (patch)
treecabc83be691530ae685c45a8bc7620ccc0e1ebdf /tests/t-disappear/Makefile
parentInitial commit. (diff)
downloaddpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.tar.xz
dpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.zip
Adding upstream version 1.20.13.upstream/1.20.13upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-disappear/Makefile')
-rw-r--r--tests/t-disappear/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/t-disappear/Makefile b/tests/t-disappear/Makefile
new file mode 100644
index 0000000..573c334
--- /dev/null
+++ b/tests/t-disappear/Makefile
@@ -0,0 +1,14 @@
+TESTS_DEB := pkg-normal pkg-disappear-0 pkg-disappear-1
+
+include ../Test.mk
+
+test-case:
+ # test disappearing package
+ $(DPKG_INSTALL) pkg-disappear-0.deb
+ $(DPKG_INSTALL) pkg-disappear-1.deb
+ $(DPKG_INSTALL) pkg-normal.deb
+
+test-clean:
+ -$(DPKG_PURGE) pkg-disappear
+ $(DPKG_PURGE) pkg-normal
+