summaryrefslogtreecommitdiffstats
path: root/tests/t-normal/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
commitb86570f63e533abcbcb97c2572e0e5732a96307b (patch)
treecabc83be691530ae685c45a8bc7620ccc0e1ebdf /tests/t-normal/Makefile
parentInitial commit. (diff)
downloaddpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.tar.xz
dpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.zip
Adding upstream version 1.20.13.upstream/1.20.13upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-normal/Makefile')
-rw-r--r--tests/t-normal/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/t-normal/Makefile b/tests/t-normal/Makefile
new file mode 100644
index 0000000..70e1dd0
--- /dev/null
+++ b/tests/t-normal/Makefile
@@ -0,0 +1,12 @@
+TESTS_DEB := pkg-normal
+
+include ../Test.mk
+
+test-case:
+ # test normal working packages
+ $(DPKG_INSTALL) pkg-normal.deb
+ $(call pkg_is_installed,pkg-normal)
+
+test-clean:
+ $(DPKG_PURGE) pkg-normal
+