summaryrefslogtreecommitdiffstats
path: root/tests/t-unpack-device
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
commitb86570f63e533abcbcb97c2572e0e5732a96307b (patch)
treecabc83be691530ae685c45a8bc7620ccc0e1ebdf /tests/t-unpack-device
parentInitial commit. (diff)
downloaddpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.tar.xz
dpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.zip
Adding upstream version 1.20.13.upstream/1.20.13upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-unpack-device')
-rw-r--r--tests/t-unpack-device/Makefile26
-rw-r--r--tests/t-unpack-device/pkg-device/DEBIAN/control8
2 files changed, 34 insertions, 0 deletions
diff --git a/tests/t-unpack-device/Makefile b/tests/t-unpack-device/Makefile
new file mode 100644
index 0000000..0dcb3ca
--- /dev/null
+++ b/tests/t-unpack-device/Makefile
@@ -0,0 +1,26 @@
+PKG := pkg-device
+
+TESTS_DEB := $(PKG)
+
+include ../Test.mk
+
+$(PKG)/test-null:
+ $(BEROOT) mknod $@ c 1 3
+
+$(PKG)/test-ram0:
+ $(BEROOT) mknod $@ b 1 0
+
+build-hook: $(PKG)/test-null $(PKG)/test-ram0
+
+clean-hook:
+ rm -f $(PKG)/test-null
+ rm -f $(PKG)/test-ram0
+
+test-case:
+ # test unpacking device files
+ $(DPKG_INSTALL) pkg-device.deb
+ $(call pkg_is_installed,pkg-device)
+
+test-clean:
+ $(DPKG_PURGE) pkg-device
+
diff --git a/tests/t-unpack-device/pkg-device/DEBIAN/control b/tests/t-unpack-device/pkg-device/DEBIAN/control
new file mode 100644
index 0000000..e5d5399
--- /dev/null
+++ b/tests/t-unpack-device/pkg-device/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: pkg-device
+Version: 0.0-1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - devices unpack
+