summaryrefslogtreecommitdiffstats
path: root/tests/t-unpack-divert-hardlink/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
commitb86570f63e533abcbcb97c2572e0e5732a96307b (patch)
treecabc83be691530ae685c45a8bc7620ccc0e1ebdf /tests/t-unpack-divert-hardlink/Makefile
parentInitial commit. (diff)
downloaddpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.tar.xz
dpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.zip
Adding upstream version 1.20.13.upstream/1.20.13upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-unpack-divert-hardlink/Makefile')
-rw-r--r--tests/t-unpack-divert-hardlink/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/t-unpack-divert-hardlink/Makefile b/tests/t-unpack-divert-hardlink/Makefile
new file mode 100644
index 0000000..75287f7
--- /dev/null
+++ b/tests/t-unpack-divert-hardlink/Makefile
@@ -0,0 +1,31 @@
+PKG := pkg-hardlink
+
+TESTS_DEB := $(PKG)
+
+include ../Test.mk
+
+$(PKG)/test-hardlink:
+ link $(PKG)/test-file $@
+
+build-hook: $(PKG)/test-hardlink
+
+clean-hook:
+ rm -f $(PKG)/test-hardlink
+
+test-case:
+ $(DPKG_DIVERT_ADD) /test-file
+ $(DPKG_DIVERT_ADD) /test-hardlink
+ # test if unpack can divert a hardlink
+ $(DPKG_INSTALL) pkg-hardlink.deb
+ $(call pkg_is_installed,pkg-hardlink)
+ test -f '$(DPKG_INSTDIR)/test-file.distrib'
+ test -f '$(DPKG_INSTDIR)/test-hardlink.distrib'
+ cmp '$(DPKG_INSTDIR)/test-file.distrib' \
+ '$(DPKG_INSTDIR)/test-hardlink.distrib'
+ test "`stat -c '%i' '$(DPKG_INSTDIR)/test-file.distrib'`" = \
+ "`stat -c '%i' '$(DPKG_INSTDIR)/test-hardlink.distrib'`"
+
+test-clean:
+ $(DPKG_PURGE) pkg-hardlink
+ $(DPKG_DIVERT_DEL) /test-file
+ $(DPKG_DIVERT_DEL) /test-hardlink