summaryrefslogtreecommitdiffstats
path: root/tests/t-conflicts
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/t-conflicts/Makefile15
-rw-r--r--tests/t-conflicts/pkg-a/DEBIAN/control8
-rw-r--r--tests/t-conflicts/pkg-b/DEBIAN/control7
3 files changed, 30 insertions, 0 deletions
diff --git a/tests/t-conflicts/Makefile b/tests/t-conflicts/Makefile
new file mode 100644
index 0000000..396d71d
--- /dev/null
+++ b/tests/t-conflicts/Makefile
@@ -0,0 +1,15 @@
+TESTS_DEB := pkg-a pkg-b
+
+include ../Test.mk
+
+test-case:
+ # test if the conflicting packages fail on install
+ ! $(DPKG_INSTALL) pkg-b.deb pkg-a.deb
+ $(call pkg_is_not_installed,pkg-a)
+ -$(DPKG_PURGE) pkg-a pkg-b
+ ! $(DPKG_INSTALL) pkg-a.deb pkg-b.deb
+ $(call pkg_is_not_installed,pkg-b)
+ -$(DPKG_PURGE) pkg-a pkg-b
+
+test-clean:
+ -$(DPKG_PURGE) pkg-a pkg-b
diff --git a/tests/t-conflicts/pkg-a/DEBIAN/control b/tests/t-conflicts/pkg-a/DEBIAN/control
new file mode 100644
index 0000000..ca34e72
--- /dev/null
+++ b/tests/t-conflicts/pkg-a/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: pkg-a
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Conflicts: pkg-b
+Description: test package - conflicting against pkg-b
diff --git a/tests/t-conflicts/pkg-b/DEBIAN/control b/tests/t-conflicts/pkg-b/DEBIAN/control
new file mode 100644
index 0000000..f723a59
--- /dev/null
+++ b/tests/t-conflicts/pkg-b/DEBIAN/control
@@ -0,0 +1,7 @@
+Package: pkg-b
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - conflicting package