summaryrefslogtreecommitdiffstats
path: root/build/build-clang/static-llvm-symbolizer.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /build/build-clang/static-llvm-symbolizer.patch
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--build/build-clang/static-llvm-symbolizer.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/build/build-clang/static-llvm-symbolizer.patch b/build/build-clang/static-llvm-symbolizer.patch
new file mode 100644
index 0000000000..ea8ebc322b
--- /dev/null
+++ b/build/build-clang/static-llvm-symbolizer.patch
@@ -0,0 +1,12 @@
+diff --git a/llvm/tools/llvm-symbolizer/CMakeLists.txt b/llvm/tools/llvm-symbolizer/CMakeLists.txt
+index 8185c296c50..13c7419fa47 100644
+--- a/llvm/tools/llvm-symbolizer/CMakeLists.txt
++++ b/llvm/tools/llvm-symbolizer/CMakeLists.txt
+@@ -13,6 +13,7 @@ set(LLVM_LINK_COMPONENTS
+ )
+
+ add_llvm_tool(llvm-symbolizer
++ DISABLE_LLVM_LINK_LLVM_DYLIB
+ llvm-symbolizer.cpp
+ )
+