summaryrefslogtreecommitdiffstats
path: root/dom/abort/AbortSignal.h
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /dom/abort/AbortSignal.h
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--dom/abort/AbortSignal.h55
1 files changed, 55 insertions, 0 deletions
diff --git a/dom/abort/AbortSignal.h b/dom/abort/AbortSignal.h
new file mode 100644
index 0000000000..2b0b49d169
--- /dev/null
+++ b/dom/abort/AbortSignal.h
@@ -0,0 +1,55 @@
+/* -*- Mode: C++; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* vim: set ts=8 sts=2 et sw=2 tw=80: */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+#ifndef mozilla_dom_AbortSignal_h
+#define mozilla_dom_AbortSignal_h
+
+#include "mozilla/dom/AbortFollower.h"
+#include "mozilla/DOMEventTargetHelper.h"
+
+namespace mozilla {
+namespace dom {
+
+// AbortSignal the spec concept includes the concept of a child signal
+// "following" a parent signal -- internally, adding abort steps to the parent
+// signal that will then signal abort on the child signal -- to propagate
+// signaling abort from one signal to another. See
+// <https://dom.spec.whatwg.org/#abortsignal-follow>.
+//
+// This requires that AbortSignal also inherit from AbortFollower.
+//
+// This ability to follow isn't directly exposed in the DOM; as of this writing
+// it appears only to be used internally in the Fetch API. It might be a good
+// idea to split AbortSignal into an implementation that can follow, and an
+// implementation that can't, to provide this complexity only when it's needed.
+class AbortSignal final : public DOMEventTargetHelper,
+ public AbortSignalImpl,
+ public AbortFollower {
+ public:
+ NS_DECL_ISUPPORTS_INHERITED
+ NS_DECL_CYCLE_COLLECTION_CLASS_INHERITED(AbortSignal, DOMEventTargetHelper)
+
+ AbortSignal(nsIGlobalObject* aGlobalObject, bool aAborted);
+
+ JSObject* WrapObject(JSContext* aCx,
+ JS::Handle<JSObject*> aGivenProto) override;
+
+ IMPL_EVENT_HANDLER(abort);
+
+ // AbortSignalImpl
+ void SignalAbort() override;
+
+ // AbortFollower
+ void RunAbortAlgorithm() override { SignalAbort(); }
+
+ private:
+ ~AbortSignal() = default;
+};
+
+} // namespace dom
+} // namespace mozilla
+
+#endif // mozilla_dom_AbortSignal_h