summaryrefslogtreecommitdiffstats
path: root/dom/webidl/ShadowRoot.webidl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /dom/webidl/ShadowRoot.webidl
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/webidl/ShadowRoot.webidl')
-rw-r--r--dom/webidl/ShadowRoot.webidl53
1 files changed, 53 insertions, 0 deletions
diff --git a/dom/webidl/ShadowRoot.webidl b/dom/webidl/ShadowRoot.webidl
new file mode 100644
index 0000000000..691c775e67
--- /dev/null
+++ b/dom/webidl/ShadowRoot.webidl
@@ -0,0 +1,53 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://dvcs.w3.org/hg/webcomponents/raw-file/tip/spec/shadow/index.html
+ *
+ * Copyright © 2012 W3C® (MIT, ERCIM, Keio), All Rights Reserved. W3C
+ * liability, trademark and document use rules apply.
+ */
+
+// https://dom.spec.whatwg.org/#enumdef-shadowrootmode
+enum ShadowRootMode {
+ "open",
+ "closed"
+};
+
+// https://dom.spec.whatwg.org/#shadowroot
+[Exposed=Window]
+interface ShadowRoot : DocumentFragment
+{
+ // Shadow DOM v1
+ readonly attribute ShadowRootMode mode;
+ readonly attribute Element host;
+
+ Element? getElementById(DOMString elementId);
+
+ // https://w3c.github.io/DOM-Parsing/#the-innerhtml-mixin
+ [CEReactions, SetterThrows]
+ attribute [TreatNullAs=EmptyString] DOMString innerHTML;
+
+ // When JS invokes importNode or createElement, the binding code needs to
+ // create a reflector, and so invoking those methods directly on the content
+ // document would cause the reflector to be created in the content scope,
+ // at which point it would be difficult to move into the UA Widget scope.
+ // As such, these methods allow UA widget code to simultaneously create nodes
+ // and associate them with the UA widget tree, so that the reflectors get
+ // created in the right scope.
+ [CEReactions, Throws, Func="IsChromeOrUAWidget"]
+ Node importNodeAndAppendChildAt(Node parentNode, Node node, optional boolean deep = false);
+
+ [CEReactions, Throws, Func="IsChromeOrUAWidget"]
+ Node createElementAndAppendChildAt(Node parentNode, DOMString localName);
+
+ // For triggering UA Widget scope in tests.
+ [ChromeOnly]
+ void setIsUAWidget();
+ [ChromeOnly]
+ boolean isUAWidget();
+};
+
+ShadowRoot includes DocumentOrShadowRoot;