summaryrefslogtreecommitdiffstats
path: root/media/audioipc/update.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /media/audioipc/update.sh
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--media/audioipc/update.sh37
1 files changed, 37 insertions, 0 deletions
diff --git a/media/audioipc/update.sh b/media/audioipc/update.sh
new file mode 100644
index 0000000000..72c871bd4a
--- /dev/null
+++ b/media/audioipc/update.sh
@@ -0,0 +1,37 @@
+# Usage: sh update.sh <upstream_src_directory>
+set -e
+
+cp -p $1/README.md .
+cp -p $1/Cargo.toml .
+
+for crate in audioipc client server; do
+ rm -fr $crate
+ mkdir $crate
+ cp -pr $1/$crate/Cargo.toml $crate
+ [ -e $1/$crate/cbindgen.toml ] && cp -pr $1/$crate/cbindgen.toml $crate
+ cp -pr $1/$crate/src $crate
+done
+
+rm -f audioipc/src/cmsghdr.c
+
+if [ -d $1/.git ]; then
+ rev=$(cd $1 && git rev-parse --verify HEAD)
+ date=$(cd $1 && git show -s --format=%ci HEAD)
+ dirty=$(cd $1 && git diff-index --name-only HEAD)
+fi
+
+if [ -n "$rev" ]; then
+ version=$rev
+ if [ -n "$dirty" ]; then
+ version=$version-dirty
+ echo "WARNING: updating from a dirty git repository."
+ fi
+ sed -i.bak -e "/The git commit ID used was/ s/[0-9a-f]\{40\}\(-dirty\)\{0,1\} .\{1,100\}/$version ($date)/" README_MOZILLA
+ rm -f README_MOZILLA.bak
+else
+ echo "Remember to update README_MOZILLA with the version details."
+fi
+
+echo "Applying gecko.patch on top of $rev"
+patch -p3 < gecko.patch
+