summaryrefslogtreecommitdiffstats
path: root/mobile/android/moz.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /mobile/android/moz.build
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--mobile/android/moz.build39
1 files changed, 39 insertions, 0 deletions
diff --git a/mobile/android/moz.build b/mobile/android/moz.build
new file mode 100644
index 0000000000..3be3dae6a0
--- /dev/null
+++ b/mobile/android/moz.build
@@ -0,0 +1,39 @@
+# -*- Mode: python; indent-tabs-mode: nil; tab-width: 40 -*-
+# vim: set filetype=python:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+with Files("**"):
+ BUG_COMPONENT = ("GeckoView", "General")
+ SCHEDULES.exclusive = ["android"]
+
+CONFIGURE_SUBST_FILES += ["installer/Makefile"]
+
+DIRS += [
+ "../locales",
+ "locales",
+]
+
+DIRS += [
+ "actors",
+ "base",
+ "chrome",
+ "components",
+ "modules",
+ "themes/geckoview",
+ "geckoview/src/androidTest/assets",
+ "app",
+ "fonts",
+]
+
+TEST_HARNESS_FILES.testing.mochitest.tests.junit += [
+ "geckoview/src/androidTest/assets/www/hello.html",
+ "geckoview/src/androidTest/assets/www/simple_redirect.sjs",
+ "geckoview/src/androidTest/assets/www/update_manifest.json",
+]
+
+SPHINX_TREES["/mobile/android"] = "docs"
+
+with Files("docs/**"):
+ SCHEDULES.exclusive = ["docs"]