summaryrefslogtreecommitdiffstats
path: root/remote/test/puppeteer/web-test-runner.config.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /remote/test/puppeteer/web-test-runner.config.js
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'remote/test/puppeteer/web-test-runner.config.js')
-rw-r--r--remote/test/puppeteer/web-test-runner.config.js43
1 files changed, 43 insertions, 0 deletions
diff --git a/remote/test/puppeteer/web-test-runner.config.js b/remote/test/puppeteer/web-test-runner.config.js
new file mode 100644
index 0000000000..8cf8ad5361
--- /dev/null
+++ b/remote/test/puppeteer/web-test-runner.config.js
@@ -0,0 +1,43 @@
+/**
+ * Copyright 2020 Google Inc. All rights reserved.
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+const { chromeLauncher } = require('@web/test-runner-chrome');
+
+module.exports = {
+ files: ['test-browser/**/*.spec.js'],
+ browsers: [
+ chromeLauncher({
+ async createPage({ browser }) {
+ const page = await browser.newPage();
+ page.evaluateOnNewDocument((wsEndpoint) => {
+ window.__ENV__ = { wsEndpoint };
+ }, browser.wsEndpoint());
+
+ return page;
+ },
+ }),
+ ],
+ plugins: [
+ {
+ // turn expect UMD into an es module
+ name: 'esmify-expect',
+ transform(context) {
+ if (context.path === '/node_modules/expect/build-es5/index.js') {
+ return `const module = {}; const exports = {};\n${context.body};\n export default module.exports;`;
+ }
+ },
+ },
+ ],
+};