summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cocoa-foundation/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/cocoa-foundation/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/cocoa-foundation/Cargo.toml')
-rw-r--r--third_party/rust/cocoa-foundation/Cargo.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/third_party/rust/cocoa-foundation/Cargo.toml b/third_party/rust/cocoa-foundation/Cargo.toml
new file mode 100644
index 0000000000..0912659f03
--- /dev/null
+++ b/third_party/rust/cocoa-foundation/Cargo.toml
@@ -0,0 +1,42 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "cocoa-foundation"
+version = "0.1.0"
+authors = ["The Servo Project Developers"]
+description = "Bindings to Cocoa Foundation for macOS"
+homepage = "https://github.com/servo/core-foundation-rs"
+license = "MIT / Apache-2.0"
+repository = "https://github.com/servo/core-foundation-rs"
+[package.metadata.docs.rs]
+default-target = "x86_64-apple-darwin"
+[dependencies.bitflags]
+version = "1.0"
+
+[dependencies.block]
+version = "0.1"
+
+[dependencies.core-foundation]
+version = "0.9"
+
+[dependencies.core-graphics-types]
+version = "0.1"
+
+[dependencies.foreign-types]
+version = "0.3"
+
+[dependencies.libc]
+version = "0.2"
+
+[dependencies.objc]
+version = "0.2.3"