summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cookie/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/cookie/README.md
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/cookie/README.md')
-rw-r--r--third_party/rust/cookie/README.md34
1 files changed, 34 insertions, 0 deletions
diff --git a/third_party/rust/cookie/README.md b/third_party/rust/cookie/README.md
new file mode 100644
index 0000000000..73dda0a7a8
--- /dev/null
+++ b/third_party/rust/cookie/README.md
@@ -0,0 +1,34 @@
+# cookie-rs
+
+[![Build Status](https://travis-ci.com/SergioBenitez/cookie-rs.svg?branch=master)](https://travis-ci.com/SergioBenitez/cookie-rs)
+[![Current Crates.io Version](https://img.shields.io/crates/v/cookie.svg)](https://crates.io/crates/cookie)
+
+A library for parsing HTTP cookies and managing cookie jars.
+
+# Usage
+
+Add the following to your `Cargo.toml`:
+
+```toml
+[dependencies]
+cookie = "0.12"
+```
+
+See the [documentation](http://docs.rs/cookie) for detailed usage information.
+
+# License
+
+This project is licensed under either of
+
+ * Apache License, Version 2.0, ([LICENSE-APACHE](LICENSE-APACHE) or
+ http://www.apache.org/licenses/LICENSE-2.0)
+ * MIT license ([LICENSE-MIT](LICENSE-MIT) or
+ http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in `cookie-rs` by you, as defined in the Apache-2.0 license, shall
+be dual licensed as above, without any additional terms or conditions.