summaryrefslogtreecommitdiffstats
path: root/third_party/rust/copyless
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/copyless
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--third_party/rust/copyless/.cargo-checksum.json1
-rw-r--r--third_party/rust/copyless/CHANGELOG.md17
-rw-r--r--third_party/rust/copyless/Cargo.toml26
-rw-r--r--third_party/rust/copyless/LICENSE373
-rw-r--r--third_party/rust/copyless/README.md35
-rw-r--r--third_party/rust/copyless/bors.toml5
-rw-r--r--third_party/rust/copyless/rustfmt.toml2
-rw-r--r--third_party/rust/copyless/src/boxed.rs62
-rw-r--r--third_party/rust/copyless/src/lib.rs11
-rw-r--r--third_party/rust/copyless/src/vec.rs75
10 files changed, 607 insertions, 0 deletions
diff --git a/third_party/rust/copyless/.cargo-checksum.json b/third_party/rust/copyless/.cargo-checksum.json
new file mode 100644
index 0000000000..cc96255dae
--- /dev/null
+++ b/third_party/rust/copyless/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"CHANGELOG.md":"fc14ff68be7982dcdf02342b449cd3db15cbe28073d242f054b75ffbfccb705b","Cargo.toml":"b2def24309e2e6b2ee8777bbbaddcce93cb787857da4d5029ea8a7b74706806e","LICENSE":"1f256ecad192880510e84ad60474eab7589218784b9a50bc7ceee34c2b91f1d5","README.md":"8e715eaac241b9555b784986105428dd181eefa060058e476b2332f54691ffec","bors.toml":"2fc93950678c7308b3685c466f55d9d93e88366c2241277691f1c42c41c1f645","rustfmt.toml":"988d2287fa5a3511acbb1168a2db2d63dbc5d3ce9f13d59c89bb63b5f0d487bb","src/boxed.rs":"01acef5ec63581b829e8f6f6620954f414eae4e05dd38cbd075fec7bf48eaec6","src/lib.rs":"9250d444179dd3138a021880752a337035b9159ee238ad3df6fe6c4668cb3573","src/vec.rs":"cbef7b318ad96f9f7bf70b84b2111f66fdda2503d4d082622a02a3855e9c6310"},"package":"6ff9c56c9fb2a49c05ef0e431485a22400af20d33226dc0764d891d09e724127"} \ No newline at end of file
diff --git a/third_party/rust/copyless/CHANGELOG.md b/third_party/rust/copyless/CHANGELOG.md
new file mode 100644
index 0000000000..c13ffa47b4
--- /dev/null
+++ b/third_party/rust/copyless/CHANGELOG.md
@@ -0,0 +1,17 @@
+# Change Log
+
+## v0.1.4 (24-06-2019)
+ - `BoxHelper`: replaced nullable pointer with NonNull
+
+## v0.1.3 (31-05-2019)
+ - fixed zero-sized box allocations
+ - fixed file permissions in the package
+
+## v0.1.2 (19-03-2019)
+ - fixed box alignment
+
+## v0.1.1 (15-03-2019)
+ - `BoxHelper` extension
+
+## v0.1 (15-03-2019)
+ - `VecHelper` extension
diff --git a/third_party/rust/copyless/Cargo.toml b/third_party/rust/copyless/Cargo.toml
new file mode 100644
index 0000000000..da3fff2597
--- /dev/null
+++ b/third_party/rust/copyless/Cargo.toml
@@ -0,0 +1,26 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "copyless"
+version = "0.1.4"
+authors = ["Dzmitry Malyshau <kvarkus@gmail.com>"]
+description = "Ways to eliminate memcpy calls when using the standard library."
+homepage = "https://github.com/kvark/copyless"
+keywords = ["containers", "memcpy"]
+license = "MPL-2.0"
+repository = "https://github.com/kvark/copyless"
+
+[lib]
+
+[dependencies]
diff --git a/third_party/rust/copyless/LICENSE b/third_party/rust/copyless/LICENSE
new file mode 100644
index 0000000000..a612ad9813
--- /dev/null
+++ b/third_party/rust/copyless/LICENSE
@@ -0,0 +1,373 @@
+Mozilla Public License Version 2.0
+==================================
+
+1. Definitions
+--------------
+
+1.1. "Contributor"
+ means each individual or legal entity that creates, contributes to
+ the creation of, or owns Covered Software.
+
+1.2. "Contributor Version"
+ means the combination of the Contributions of others (if any) used
+ by a Contributor and that particular Contributor's Contribution.
+
+1.3. "Contribution"
+ means Covered Software of a particular Contributor.
+
+1.4. "Covered Software"
+ means Source Code Form to which the initial Contributor has attached
+ the notice in Exhibit A, the Executable Form of such Source Code
+ Form, and Modifications of such Source Code Form, in each case
+ including portions thereof.
+
+1.5. "Incompatible With Secondary Licenses"
+ means
+
+ (a) that the initial Contributor has attached the notice described
+ in Exhibit B to the Covered Software; or
+
+ (b) that the Covered Software was made available under the terms of
+ version 1.1 or earlier of the License, but not also under the
+ terms of a Secondary License.
+
+1.6. "Executable Form"
+ means any form of the work other than Source Code Form.
+
+1.7. "Larger Work"
+ means a work that combines Covered Software with other material, in
+ a separate file or files, that is not Covered Software.
+
+1.8. "License"
+ means this document.
+
+1.9. "Licensable"
+ means having the right to grant, to the maximum extent possible,
+ whether at the time of the initial grant or subsequently, any and
+ all of the rights conveyed by this License.
+
+1.10. "Modifications"
+ means any of the following:
+
+ (a) any file in Source Code Form that results from an addition to,
+ deletion from, or modification of the contents of Covered
+ Software; or
+
+ (b) any new file in Source Code Form that contains any Covered
+ Software.
+
+1.11. "Patent Claims" of a Contributor
+ means any patent claim(s), including without limitation, method,
+ process, and apparatus claims, in any patent Licensable by such
+ Contributor that would be infringed, but for the grant of the
+ License, by the making, using, selling, offering for sale, having
+ made, import, or transfer of either its Contributions or its
+ Contributor Version.
+
+1.12. "Secondary License"
+ means either the GNU General Public License, Version 2.0, the GNU
+ Lesser General Public License, Version 2.1, the GNU Affero General
+ Public License, Version 3.0, or any later versions of those
+ licenses.
+
+1.13. "Source Code Form"
+ means the form of the work preferred for making modifications.
+
+1.14. "You" (or "Your")
+ means an individual or a legal entity exercising rights under this
+ License. For legal entities, "You" includes any entity that
+ controls, is controlled by, or is under common control with You. For
+ purposes of this definition, "control" means (a) the power, direct
+ or indirect, to cause the direction or management of such entity,
+ whether by contract or otherwise, or (b) ownership of more than
+ fifty percent (50%) of the outstanding shares or beneficial
+ ownership of such entity.
+
+2. License Grants and Conditions
+--------------------------------
+
+2.1. Grants
+
+Each Contributor hereby grants You a world-wide, royalty-free,
+non-exclusive license:
+
+(a) under intellectual property rights (other than patent or trademark)
+ Licensable by such Contributor to use, reproduce, make available,
+ modify, display, perform, distribute, and otherwise exploit its
+ Contributions, either on an unmodified basis, with Modifications, or
+ as part of a Larger Work; and
+
+(b) under Patent Claims of such Contributor to make, use, sell, offer
+ for sale, have made, import, and otherwise transfer either its
+ Contributions or its Contributor Version.
+
+2.2. Effective Date
+
+The licenses granted in Section 2.1 with respect to any Contribution
+become effective for each Contribution on the date the Contributor first
+distributes such Contribution.
+
+2.3. Limitations on Grant Scope
+
+The licenses granted in this Section 2 are the only rights granted under
+this License. No additional rights or licenses will be implied from the
+distribution or licensing of Covered Software under this License.
+Notwithstanding Section 2.1(b) above, no patent license is granted by a
+Contributor:
+
+(a) for any code that a Contributor has removed from Covered Software;
+ or
+
+(b) for infringements caused by: (i) Your and any other third party's
+ modifications of Covered Software, or (ii) the combination of its
+ Contributions with other software (except as part of its Contributor
+ Version); or
+
+(c) under Patent Claims infringed by Covered Software in the absence of
+ its Contributions.
+
+This License does not grant any rights in the trademarks, service marks,
+or logos of any Contributor (except as may be necessary to comply with
+the notice requirements in Section 3.4).
+
+2.4. Subsequent Licenses
+
+No Contributor makes additional grants as a result of Your choice to
+distribute the Covered Software under a subsequent version of this
+License (see Section 10.2) or under the terms of a Secondary License (if
+permitted under the terms of Section 3.3).
+
+2.5. Representation
+
+Each Contributor represents that the Contributor believes its
+Contributions are its original creation(s) or it has sufficient rights
+to grant the rights to its Contributions conveyed by this License.
+
+2.6. Fair Use
+
+This License is not intended to limit any rights You have under
+applicable copyright doctrines of fair use, fair dealing, or other
+equivalents.
+
+2.7. Conditions
+
+Sections 3.1, 3.2, 3.3, and 3.4 are conditions of the licenses granted
+in Section 2.1.
+
+3. Responsibilities
+-------------------
+
+3.1. Distribution of Source Form
+
+All distribution of Covered Software in Source Code Form, including any
+Modifications that You create or to which You contribute, must be under
+the terms of this License. You must inform recipients that the Source
+Code Form of the Covered Software is governed by the terms of this
+License, and how they can obtain a copy of this License. You may not
+attempt to alter or restrict the recipients' rights in the Source Code
+Form.
+
+3.2. Distribution of Executable Form
+
+If You distribute Covered Software in Executable Form then:
+
+(a) such Covered Software must also be made available in Source Code
+ Form, as described in Section 3.1, and You must inform recipients of
+ the Executable Form how they can obtain a copy of such Source Code
+ Form by reasonable means in a timely manner, at a charge no more
+ than the cost of distribution to the recipient; and
+
+(b) You may distribute such Executable Form under the terms of this
+ License, or sublicense it under different terms, provided that the
+ license for the Executable Form does not attempt to limit or alter
+ the recipients' rights in the Source Code Form under this License.
+
+3.3. Distribution of a Larger Work
+
+You may create and distribute a Larger Work under terms of Your choice,
+provided that You also comply with the requirements of this License for
+the Covered Software. If the Larger Work is a combination of Covered
+Software with a work governed by one or more Secondary Licenses, and the
+Covered Software is not Incompatible With Secondary Licenses, this
+License permits You to additionally distribute such Covered Software
+under the terms of such Secondary License(s), so that the recipient of
+the Larger Work may, at their option, further distribute the Covered
+Software under the terms of either this License or such Secondary
+License(s).
+
+3.4. Notices
+
+You may not remove or alter the substance of any license notices
+(including copyright notices, patent notices, disclaimers of warranty,
+or limitations of liability) contained within the Source Code Form of
+the Covered Software, except that You may alter any license notices to
+the extent required to remedy known factual inaccuracies.
+
+3.5. Application of Additional Terms
+
+You may choose to offer, and to charge a fee for, warranty, support,
+indemnity or liability obligations to one or more recipients of Covered
+Software. However, You may do so only on Your own behalf, and not on
+behalf of any Contributor. You must make it absolutely clear that any
+such warranty, support, indemnity, or liability obligation is offered by
+You alone, and You hereby agree to indemnify every Contributor for any
+liability incurred by such Contributor as a result of warranty, support,
+indemnity or liability terms You offer. You may include additional
+disclaimers of warranty and limitations of liability specific to any
+jurisdiction.
+
+4. Inability to Comply Due to Statute or Regulation
+---------------------------------------------------
+
+If it is impossible for You to comply with any of the terms of this
+License with respect to some or all of the Covered Software due to
+statute, judicial order, or regulation then You must: (a) comply with
+the terms of this License to the maximum extent possible; and (b)
+describe the limitations and the code they affect. Such description must
+be placed in a text file included with all distributions of the Covered
+Software under this License. Except to the extent prohibited by statute
+or regulation, such description must be sufficiently detailed for a
+recipient of ordinary skill to be able to understand it.
+
+5. Termination
+--------------
+
+5.1. The rights granted under this License will terminate automatically
+if You fail to comply with any of its terms. However, if You become
+compliant, then the rights granted under this License from a particular
+Contributor are reinstated (a) provisionally, unless and until such
+Contributor explicitly and finally terminates Your grants, and (b) on an
+ongoing basis, if such Contributor fails to notify You of the
+non-compliance by some reasonable means prior to 60 days after You have
+come back into compliance. Moreover, Your grants from a particular
+Contributor are reinstated on an ongoing basis if such Contributor
+notifies You of the non-compliance by some reasonable means, this is the
+first time You have received notice of non-compliance with this License
+from such Contributor, and You become compliant prior to 30 days after
+Your receipt of the notice.
+
+5.2. If You initiate litigation against any entity by asserting a patent
+infringement claim (excluding declaratory judgment actions,
+counter-claims, and cross-claims) alleging that a Contributor Version
+directly or indirectly infringes any patent, then the rights granted to
+You by any and all Contributors for the Covered Software under Section
+2.1 of this License shall terminate.
+
+5.3. In the event of termination under Sections 5.1 or 5.2 above, all
+end user license agreements (excluding distributors and resellers) which
+have been validly granted by You or Your distributors under this License
+prior to termination shall survive termination.
+
+************************************************************************
+* *
+* 6. Disclaimer of Warranty *
+* ------------------------- *
+* *
+* Covered Software is provided under this License on an "as is" *
+* basis, without warranty of any kind, either expressed, implied, or *
+* statutory, including, without limitation, warranties that the *
+* Covered Software is free of defects, merchantable, fit for a *
+* particular purpose or non-infringing. The entire risk as to the *
+* quality and performance of the Covered Software is with You. *
+* Should any Covered Software prove defective in any respect, You *
+* (not any Contributor) assume the cost of any necessary servicing, *
+* repair, or correction. This disclaimer of warranty constitutes an *
+* essential part of this License. No use of any Covered Software is *
+* authorized under this License except under this disclaimer. *
+* *
+************************************************************************
+
+************************************************************************
+* *
+* 7. Limitation of Liability *
+* -------------------------- *
+* *
+* Under no circumstances and under no legal theory, whether tort *
+* (including negligence), contract, or otherwise, shall any *
+* Contributor, or anyone who distributes Covered Software as *
+* permitted above, be liable to You for any direct, indirect, *
+* special, incidental, or consequential damages of any character *
+* including, without limitation, damages for lost profits, loss of *
+* goodwill, work stoppage, computer failure or malfunction, or any *
+* and all other commercial damages or losses, even if such party *
+* shall have been informed of the possibility of such damages. This *
+* limitation of liability shall not apply to liability for death or *
+* personal injury resulting from such party's negligence to the *
+* extent applicable law prohibits such limitation. Some *
+* jurisdictions do not allow the exclusion or limitation of *
+* incidental or consequential damages, so this exclusion and *
+* limitation may not apply to You. *
+* *
+************************************************************************
+
+8. Litigation
+-------------
+
+Any litigation relating to this License may be brought only in the
+courts of a jurisdiction where the defendant maintains its principal
+place of business and such litigation shall be governed by laws of that
+jurisdiction, without reference to its conflict-of-law provisions.
+Nothing in this Section shall prevent a party's ability to bring
+cross-claims or counter-claims.
+
+9. Miscellaneous
+----------------
+
+This License represents the complete agreement concerning the subject
+matter hereof. If any provision of this License is held to be
+unenforceable, such provision shall be reformed only to the extent
+necessary to make it enforceable. Any law or regulation which provides
+that the language of a contract shall be construed against the drafter
+shall not be used to construe this License against a Contributor.
+
+10. Versions of the License
+---------------------------
+
+10.1. New Versions
+
+Mozilla Foundation is the license steward. Except as provided in Section
+10.3, no one other than the license steward has the right to modify or
+publish new versions of this License. Each version will be given a
+distinguishing version number.
+
+10.2. Effect of New Versions
+
+You may distribute the Covered Software under the terms of the version
+of the License under which You originally received the Covered Software,
+or under the terms of any subsequent version published by the license
+steward.
+
+10.3. Modified Versions
+
+If you create software not governed by this License, and you want to
+create a new license for such software, you may create and use a
+modified version of this License if you rename the license and remove
+any references to the name of the license steward (except to note that
+such modified license differs from this License).
+
+10.4. Distributing Source Code Form that is Incompatible With Secondary
+Licenses
+
+If You choose to distribute Source Code Form that is Incompatible With
+Secondary Licenses under the terms of this version of the License, the
+notice described in Exhibit B of this License must be attached.
+
+Exhibit A - Source Code Form License Notice
+-------------------------------------------
+
+ This Source Code Form is subject to the terms of the Mozilla Public
+ License, v. 2.0. If a copy of the MPL was not distributed with this
+ file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+If it is not possible or desirable to put the notice in a particular
+file, then You may include the notice in a location (such as a LICENSE
+file in a relevant directory) where a recipient would be likely to look
+for such a notice.
+
+You may add additional accurate notices of copyright ownership.
+
+Exhibit B - "Incompatible With Secondary Licenses" Notice
+---------------------------------------------------------
+
+ This Source Code Form is "Incompatible With Secondary Licenses", as
+ defined by the Mozilla Public License, v. 2.0.
diff --git a/third_party/rust/copyless/README.md b/third_party/rust/copyless/README.md
new file mode 100644
index 0000000000..8caf5448b6
--- /dev/null
+++ b/third_party/rust/copyless/README.md
@@ -0,0 +1,35 @@
+## copyless
+[![Build Status](https://travis-ci.org/kvark/copyless.svg)](https://travis-ci.org/kvark/copyless)
+[![Crates.io](https://img.shields.io/crates/v/copyless.svg)](https://crates.io/crates/copyless)
+
+Rust abstractions can be zero cost in theory, but often reveal quite a few unnecessary `memcpy` calls in practice. This library provides a number of trait extensions for standard containers that expose API that is more friendly to LLVM optimization passes and doesn't end up with as many copies.
+
+It aims to accelerate [WebRender](https://github.com/servo/webrender) and [gfx-rs](https://github.com/gfx-rs/gfx).
+
+## Background
+
+The `memcpy` instructions showed in profiles of WebRender running in Gecko. @jrmuizel built a tool called [memcpy-find](https://github.com/jrmuizel/memcpy-find) that analyzes LLVM IR and spews out the call stacks that end up producing `memcpy` instructions. We figured out a way to convince the compiler to eliminate the copies. This library attempts to make these ways available to Rust ecosystem, at least until the compiler gets smart enough ;)
+
+## Here is a small example
+
+```rust
+use copyless::BoxHelper;
+
+enum Foo {
+ Small(i8),
+ Big([f32; 100]),
+}
+
+#[inline(never)]
+fn foo() -> Box<Foo> {
+ Box::new(Foo::Small(4)) // this has 1 memcopy
+ //Box::alloc().init(Foo::Small(4)) // this has 0 memcopies
+}
+
+fn main() {
+ let z = foo();
+ println!("{:?}", &*z as *const _);
+}
+```
+
+Playground [permalink](https://play.rust-lang.org/?version=stable&mode=release&edition=2018&gist=579ab13345b1266752b1fa4400194cc7).
diff --git a/third_party/rust/copyless/bors.toml b/third_party/rust/copyless/bors.toml
new file mode 100644
index 0000000000..dccefd8780
--- /dev/null
+++ b/third_party/rust/copyless/bors.toml
@@ -0,0 +1,5 @@
+status = [
+ "continuous-integration/travis-ci/push",
+]
+
+timeout_sec = 18000 # 5 hours
diff --git a/third_party/rust/copyless/rustfmt.toml b/third_party/rust/copyless/rustfmt.toml
new file mode 100644
index 0000000000..03cbecbdef
--- /dev/null
+++ b/third_party/rust/copyless/rustfmt.toml
@@ -0,0 +1,2 @@
+newline_style = "Native"
+spaces_around_ranges = true
diff --git a/third_party/rust/copyless/src/boxed.rs b/third_party/rust/copyless/src/boxed.rs
new file mode 100644
index 0000000000..e3f3daaa9c
--- /dev/null
+++ b/third_party/rust/copyless/src/boxed.rs
@@ -0,0 +1,62 @@
+use std::{
+ alloc, mem,
+ ptr::{self, NonNull},
+};
+
+/// A typesafe helper that stores the allocated pointer without the data initialized.
+pub struct BoxAllocation<T>(
+ // ptr cannot be null since it would mean the allocation failed.
+ // Note: covariance is acceptable since this eventually becomes a `Box<T>`,
+ // which is covariant too.
+ NonNull<T>,
+);
+
+impl<T> BoxAllocation<T> {
+ /// Consumes self and writes the given value into the allocation.
+ #[inline(always)] // if this does not get inlined then copying happens
+ pub fn init(self, value: T) -> Box<T> {
+ if mem::size_of::<T>() == 0 {
+ return Box::new(value);
+ }
+
+ unsafe {
+ let ptr = self.0.as_ptr();
+ mem::forget(self);
+ ptr::write(ptr, value);
+ Box::from_raw(ptr)
+ }
+ }
+}
+
+impl<T> Drop for BoxAllocation<T> {
+ fn drop(&mut self) {
+ if mem::size_of::<T>() == 0 {
+ return;
+ }
+
+ let layout = alloc::Layout::new::<T>();
+ unsafe {
+ alloc::dealloc(self.0.as_ptr() as *mut u8, layout);
+ }
+ }
+}
+
+/// Helper trait for a `Box` type that allocates up-front.
+pub trait BoxHelper<T> {
+ /// Allocates the storage without providing any data.
+ fn alloc() -> BoxAllocation<T>;
+}
+
+impl<T> BoxHelper<T> for Box<T> {
+ fn alloc() -> BoxAllocation<T> {
+ if mem::size_of::<T>() == 0 {
+ return BoxAllocation(NonNull::dangling());
+ }
+
+ let layout = alloc::Layout::new::<T>();
+ BoxAllocation(
+ NonNull::new(unsafe { alloc::alloc(layout) as *mut T })
+ .unwrap_or_else(|| alloc::handle_alloc_error(layout)), // oom
+ )
+ }
+}
diff --git a/third_party/rust/copyless/src/lib.rs b/third_party/rust/copyless/src/lib.rs
new file mode 100644
index 0000000000..e06bec0f83
--- /dev/null
+++ b/third_party/rust/copyless/src/lib.rs
@@ -0,0 +1,11 @@
+#![warn(missing_docs)]
+
+//! Helper extensions of standard containers that allow memcopy-less operation.
+
+pub use self::{
+ boxed::{BoxAllocation, BoxHelper},
+ vec::{VecAllocation, VecEntry, VecHelper},
+};
+
+mod boxed;
+mod vec;
diff --git a/third_party/rust/copyless/src/vec.rs b/third_party/rust/copyless/src/vec.rs
new file mode 100644
index 0000000000..f901dc98e5
--- /dev/null
+++ b/third_party/rust/copyless/src/vec.rs
@@ -0,0 +1,75 @@
+use std::ptr;
+
+/// A typesafe helper that separates new value construction from
+/// vector growing, allowing LLVM to ideally construct the element in place.
+pub struct VecAllocation<'a, T: 'a> {
+ vec: &'a mut Vec<T>,
+ index: usize,
+}
+
+impl<'a, T> VecAllocation<'a, T> {
+ /// Consumes self and writes the given value into the allocation.
+ // writing is safe because alloc() ensured enough capacity
+ // and `Allocation` holds a mutable borrow to prevent anyone else
+ // from breaking this invariant.
+ #[inline(always)]
+ pub fn init(self, value: T) -> usize {
+ unsafe {
+ ptr::write(self.vec.as_mut_ptr().add(self.index), value);
+ self.vec.set_len(self.index + 1);
+ }
+ self.index
+ }
+}
+
+/// An entry into a vector, similar to `std::collections::hash_map::Entry`.
+pub enum VecEntry<'a, T: 'a> {
+ /// Entry has just been freshly allocated.
+ Vacant(VecAllocation<'a, T>),
+ /// Existing entry.
+ Occupied(&'a mut T),
+}
+
+impl<'a, T> VecEntry<'a, T> {
+ /// Sets the value for this entry.
+ #[inline(always)]
+ pub fn set(self, value: T) {
+ match self {
+ VecEntry::Vacant(alloc) => { alloc.init(value); }
+ VecEntry::Occupied(slot) => { *slot = value; }
+ }
+ }
+}
+
+/// Helper trait for a `Vec` type that allocates up-front.
+pub trait VecHelper<T> {
+ /// Grows the vector by a single entry, returning the allocation.
+ fn alloc(&mut self) -> VecAllocation<T>;
+ /// Either returns an existing element, or grows the vector by one.
+ /// Doesn't expect indices to be higher than the current length.
+ fn entry(&mut self, index: usize) -> VecEntry<T>;
+}
+
+impl<T> VecHelper<T> for Vec<T> {
+ fn alloc(&mut self) -> VecAllocation<T> {
+ let index = self.len();
+ if self.capacity() == index {
+ self.reserve(1);
+ }
+ VecAllocation {
+ vec: self,
+ index,
+ }
+ }
+
+ fn entry(&mut self, index: usize) -> VecEntry<T> {
+ if index < self.len() {
+ VecEntry::Occupied(unsafe {
+ self.get_unchecked_mut(index)
+ })
+ } else {
+ assert_eq!(index, self.len());
+ VecEntry::Vacant(self.alloc())
+ }
+ }
+}