summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cranelift-entity-0.41.0/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/cranelift-entity-0.41.0/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/cranelift-entity-0.41.0/Cargo.toml')
-rw-r--r--third_party/rust/cranelift-entity-0.41.0/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/third_party/rust/cranelift-entity-0.41.0/Cargo.toml b/third_party/rust/cranelift-entity-0.41.0/Cargo.toml
new file mode 100644
index 0000000000..3aecf29d9b
--- /dev/null
+++ b/third_party/rust/cranelift-entity-0.41.0/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+authors = ["The Cranelift Project Developers"]
+name = "cranelift-entity"
+version = "0.41.0"
+description = "Data structures using entity references as mapping keys"
+license = "Apache-2.0 WITH LLVM-exception"
+documentation = "https://cranelift.readthedocs.io/"
+repository = "https://github.com/CraneStation/cranelift"
+categories = ["no-std"]
+readme = "README.md"
+keywords = ["entity", "set", "map"]
+edition = "2018"
+
+[dependencies]
+serde = { version = "1.0.94", features = ["derive"], optional = true }
+
+[features]
+default = ["std"]
+std = []
+core = []
+enable-serde = ["serde"]
+
+[badges]
+maintenance = { status = "experimental" }
+travis-ci = { repository = "CraneStation/cranelift" }