summaryrefslogtreecommitdiffstats
path: root/third_party/rust/ece/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/ece/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/ece/Cargo.toml')
-rw-r--r--third_party/rust/ece/Cargo.toml60
1 files changed, 60 insertions, 0 deletions
diff --git a/third_party/rust/ece/Cargo.toml b/third_party/rust/ece/Cargo.toml
new file mode 100644
index 0000000000..111322e31b
--- /dev/null
+++ b/third_party/rust/ece/Cargo.toml
@@ -0,0 +1,60 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "ece"
+version = "1.2.1"
+authors = ["Edouard Oger <eoger@fastmail.com>", "JR Conlin <jrconlin@gmail.com>"]
+description = "Encrypted Content-Encoding for HTTP Rust implementation."
+keywords = ["http-ece", "web-push"]
+license = "MPL-2.0"
+repository = "https://github.com/mozilla/rust-ece"
+[dependencies.base64]
+version = "0.12"
+
+[dependencies.byteorder]
+version = "1.3"
+
+[dependencies.hkdf]
+version = "0.9"
+optional = true
+
+[dependencies.lazy_static]
+version = "1.4"
+optional = true
+
+[dependencies.once_cell]
+version = "1.4"
+
+[dependencies.openssl]
+version = "0.10"
+optional = true
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+optional = true
+
+[dependencies.sha2]
+version = "0.9"
+optional = true
+
+[dependencies.thiserror]
+version = "1.0"
+[dev-dependencies.hex]
+version = "0.4"
+
+[features]
+backend-openssl = ["openssl", "lazy_static", "hkdf", "sha2"]
+default = ["backend-openssl", "serializable-keys"]
+serializable-keys = ["serde"]