summaryrefslogtreecommitdiffstats
path: root/third_party/rust/mapped_hyph/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/mapped_hyph/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/mapped_hyph/Cargo.toml')
-rw-r--r--third_party/rust/mapped_hyph/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/third_party/rust/mapped_hyph/Cargo.toml b/third_party/rust/mapped_hyph/Cargo.toml
new file mode 100644
index 0000000000..abaffe49f8
--- /dev/null
+++ b/third_party/rust/mapped_hyph/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "mapped_hyph"
+description = "Hyphenation using precompiled memory-mapped tables"
+version = "0.4.3"
+authors = ["Jonathan Kew <jfkthame@gmail.com>"]
+license = "MIT/Apache-2.0"
+edition = "2018"
+
+[dependencies]
+memmap = "0.7.0"
+arrayref = "0.3.5"
+log = "0.4"
+
+[dev-dependencies]
+criterion = "0.3"
+
+[[bench]]
+name = "bench"
+harness = false