summaryrefslogtreecommitdiffstats
path: root/third_party/rust/memoffset-0.5.1/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/memoffset-0.5.1/README.md
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--third_party/rust/memoffset-0.5.1/README.md54
1 files changed, 54 insertions, 0 deletions
diff --git a/third_party/rust/memoffset-0.5.1/README.md b/third_party/rust/memoffset-0.5.1/README.md
new file mode 100644
index 0000000000..9b64e87b3a
--- /dev/null
+++ b/third_party/rust/memoffset-0.5.1/README.md
@@ -0,0 +1,54 @@
+# memoffset #
+
+[![](http://meritbadge.herokuapp.com/memoffset)](https://crates.io/crates/memoffset)
+
+C-Like `offset_of` functionality for Rust structs.
+
+Introduces the following macros:
+ * `offset_of!` for obtaining the offset of a member of a struct.
+ * `span_of!` for obtaining the range that a field, or fields, span.
+
+`memoffset` works under `no_std` environments.
+
+## Usage ##
+Add the following dependency to your `Cargo.toml`:
+
+```toml
+[dependencies]
+memoffset = "0.3"
+```
+
+Versions ">= 0.3" can be used in a constant expression context (though not in a `const fn`),
+but require a rust version greater than or equal to 1.33.
+These versions will compile fine with rustc versions greater or equal to 1.19, but will
+lack support for constant expression.
+
+If you wish to use an older rustc version, lock your dependency to "0.2"
+
+Add the following lines at the top of your `main.rs` or `lib.rs` files.
+
+```rust
+#[macro_use]
+extern crate memoffset;
+```
+
+## Examples ##
+```rust
+#[repr(C, packed)]
+struct Foo {
+ a: u32,
+ b: u32,
+ c: [u8; 5],
+ d: u32,
+}
+
+assert_eq!(offset_of!(Foo, b), 4);
+assert_eq!(offset_of!(Foo, c[3]), 11);
+
+assert_eq!(span_of!(Foo, a), 0..4);
+assert_eq!(span_of!(Foo, a .. c), 0..8);
+assert_eq!(span_of!(Foo, a .. c[1]), 0..9);
+assert_eq!(span_of!(Foo, a ..= c[1]), 0..10);
+assert_eq!(span_of!(Foo, ..= d), 0..14);
+assert_eq!(span_of!(Foo, b ..), 4..17);
+```