summaryrefslogtreecommitdiffstats
path: root/third_party/rust/mp4parse_capi/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/mp4parse_capi/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/mp4parse_capi/Cargo.toml')
-rw-r--r--third_party/rust/mp4parse_capi/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/third_party/rust/mp4parse_capi/Cargo.toml b/third_party/rust/mp4parse_capi/Cargo.toml
new file mode 100644
index 0000000000..b4ede98c93
--- /dev/null
+++ b/third_party/rust/mp4parse_capi/Cargo.toml
@@ -0,0 +1,33 @@
+[package]
+name = "mp4parse_capi"
+version = "0.11.4"
+authors = [
+ "Ralph Giles <giles@mozilla.com>",
+ "Matthew Gregan <kinetik@flim.org>",
+ "Alfredo Yang <ayang@mozilla.com>",
+ "Jon Bauman <jbauman@mozilla.com>",
+]
+
+description = "Parser for ISO base media file format (mp4)"
+documentation = "https://docs.rs/mp4parse_capi/"
+license = "MPL-2.0"
+
+repository = "https://github.com/mozilla/mp4parse-rust"
+
+# Avoid complaints about trying to package test files.
+exclude = [
+ "*.mp4",
+]
+
+[badges]
+travis-ci = { repository = "https://github.com/mozilla/mp4parse-rust" }
+
+[dependencies]
+byteorder = "1.2.1"
+fallible_collections = { version = "0.3", features = ["std_io"] }
+log = "0.4"
+mp4parse = {version = "0.11.2", path = "../mp4parse"}
+num-traits = "=0.2.10"
+
+[dev-dependencies]
+env_logger = "0.7.1"