summaryrefslogtreecommitdiffstats
path: root/third_party/rust/naga/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/naga/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/naga/Cargo.toml')
-rw-r--r--third_party/rust/naga/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/third_party/rust/naga/Cargo.toml b/third_party/rust/naga/Cargo.toml
new file mode 100644
index 0000000000..55d65a7534
--- /dev/null
+++ b/third_party/rust/naga/Cargo.toml
@@ -0,0 +1,39 @@
+[package]
+name = "naga"
+version = "0.2.0"
+authors = ["Dzmitry Malyshau <kvarkus@gmail.com>"]
+edition = "2018"
+description = "Shader translation infrastructure"
+homepage = "https://github.com/gfx-rs/naga"
+repository = "https://github.com/gfx-rs/naga"
+keywords = ["shader", "SPIR-V"]
+license = "MIT OR Apache-2.0"
+
+[dependencies]
+bitflags = "1"
+fxhash = "0.2"
+log = "0.4"
+num-traits = "0.2"
+spirv = { package = "spirv_headers", version = "1.4.2", optional = true }
+pomelo = { version = "0.1.4", optional = true }
+thiserror = "1.0.21"
+serde = { version = "1.0", features = ["derive"], optional = true }
+petgraph = { version ="0.5", optional = true }
+
+[features]
+default = []
+glsl-in = ["pomelo"]
+glsl-validate = []
+glsl-out = ["petgraph"]
+msl-out = []
+serialize = ["serde"]
+deserialize = ["serde"]
+spv-in = ["petgraph", "spirv"]
+spv-out = ["spirv"]
+wgsl-in = []
+
+[dev-dependencies]
+difference = "2.0"
+env_logger = "0.6"
+ron = "0.6"
+serde = { version = "1.0", features = ["derive"] }