summaryrefslogtreecommitdiffstats
path: root/third_party/rust/rust-argon2/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/rust-argon2/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--third_party/rust/rust-argon2/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/third_party/rust/rust-argon2/Cargo.toml b/third_party/rust/rust-argon2/Cargo.toml
new file mode 100644
index 0000000000..65e3547997
--- /dev/null
+++ b/third_party/rust/rust-argon2/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "rust-argon2"
+version = "0.5.1"
+authors = ["Martijn Rijkeboer <mrr@sru-systems.com>"]
+description = "Rust implementation of the Argon2 password hashing function."
+homepage = "https://github.com/sru-systems/rust-argon2"
+documentation = "https://docs.sru-systems.com/rust-argon2/0.5.0/argon2/"
+readme = "README.md"
+keywords = ["argon2", "argon2d", "argon2i", "hash", "password"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/sru-systems/rust-argon2"
+
+[lib]
+name = "argon2"
+[dependencies.base64]
+version = "0.10"
+
+[dependencies.blake2b_simd]
+version = "0.5"
+
+[dependencies.crossbeam-utils]
+version = "0.6"
+[dev-dependencies.hex]
+version = "0.3"