summaryrefslogtreecommitdiffstats
path: root/third_party/rust/tokio-io/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/tokio-io/README.md
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/tokio-io/README.md')
-rw-r--r--third_party/rust/tokio-io/README.md37
1 files changed, 37 insertions, 0 deletions
diff --git a/third_party/rust/tokio-io/README.md b/third_party/rust/tokio-io/README.md
new file mode 100644
index 0000000000..324e7e6c7b
--- /dev/null
+++ b/third_party/rust/tokio-io/README.md
@@ -0,0 +1,37 @@
+# tokio-io
+
+Core I/O abstractions for the Tokio stack.
+
+[![Build Status](https://travis-ci.org/tokio-rs/tokio-io.svg?branch=master)](https://travis-ci.org/tokio-rs/tokio-io)
+
+[Documentation](https://docs.rs/tokio-io)
+
+## Usage
+
+First, add this to your `Cargo.toml`:
+
+```toml
+[dependencies]
+tokio-io = "0.1"
+```
+
+Next, add this to your crate:
+
+```rust
+extern crate tokio_io;
+```
+
+You can find extensive documentation and examples about how to use this crate
+online at [https://tokio.rs](https://tokio.rs). The [API
+documentation](https://docs.rs/tokio-io) is also a great place to get started
+for the nitty-gritty.
+
+## License
+
+This project is licensed under the [MIT license](LICENSE).
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in Tokio by you, shall be licensed as MIT, without any additional
+terms or conditions.