summaryrefslogtreecommitdiffstats
path: root/third_party/rust/tokio-uds/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/tokio-uds/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/tokio-uds/Cargo.toml')
-rw-r--r--third_party/rust/tokio-uds/Cargo.toml56
1 files changed, 56 insertions, 0 deletions
diff --git a/third_party/rust/tokio-uds/Cargo.toml b/third_party/rust/tokio-uds/Cargo.toml
new file mode 100644
index 0000000000..e950fe54d4
--- /dev/null
+++ b/third_party/rust/tokio-uds/Cargo.toml
@@ -0,0 +1,56 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "tokio-uds"
+version = "0.2.5"
+authors = ["Carl Lerche <me@carllerche.com>"]
+description = "Unix Domain sockets for Tokio\n"
+homepage = "https://github.com/tokio-rs/tokio"
+documentation = "https://docs.rs/tokio-uds/0.2.5/tokio_uds/"
+categories = ["asynchronous"]
+license = "MIT"
+repository = "https://github.com/tokio-rs/tokio"
+[dependencies.bytes]
+version = "0.4.8"
+
+[dependencies.futures]
+version = "0.1.21"
+
+[dependencies.iovec]
+version = "0.1.2"
+
+[dependencies.libc]
+version = "0.2.42"
+
+[dependencies.log]
+version = "0.4.2"
+
+[dependencies.mio]
+version = "0.6.14"
+
+[dependencies.mio-uds]
+version = "0.6.5"
+
+[dependencies.tokio-codec]
+version = "0.1.0"
+
+[dependencies.tokio-io]
+version = "0.1.6"
+
+[dependencies.tokio-reactor]
+version = "0.1.1"
+[dev-dependencies.tempfile]
+version = "3"
+
+[dev-dependencies.tokio]
+version = "0.1.6"