summaryrefslogtreecommitdiffstats
path: root/build/clang-plugin/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'build/clang-plugin/Makefile.in')
-rw-r--r--build/clang-plugin/Makefile.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/build/clang-plugin/Makefile.in b/build/clang-plugin/Makefile.in
new file mode 100644
index 0000000000..39bcd37573
--- /dev/null
+++ b/build/clang-plugin/Makefile.in
@@ -0,0 +1,19 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+include $(topsrcdir)/config/config.mk
+
+HOST_LDFLAGS := $(LLVM_LDFLAGS) $(CLANG_LDFLAGS)
+
+ifeq ($(HOST_OS_ARCH),WINNT)
+# clang-plugin.dll needs to be deterministic for sccache hashes
+HOST_LDFLAGS += -brepro
+else
+HOST_LDFLAGS += -shared
+endif
+
+# Use the default OS X deployment target to enable using the libc++ headers
+# correctly. Note that the binary produced here is a host tool and doesn't need
+# to be distributed.
+MACOSX_DEPLOYMENT_TARGET :=