summaryrefslogtreecommitdiffstats
path: root/build/debian-packages/cmake-jessie.diff
diff options
context:
space:
mode:
Diffstat (limited to 'build/debian-packages/cmake-jessie.diff')
-rw-r--r--build/debian-packages/cmake-jessie.diff70
1 files changed, 70 insertions, 0 deletions
diff --git a/build/debian-packages/cmake-jessie.diff b/build/debian-packages/cmake-jessie.diff
new file mode 100644
index 0000000000..7fd301f908
--- /dev/null
+++ b/build/debian-packages/cmake-jessie.diff
@@ -0,0 +1,70 @@
+diff -Nru cmake-3.16.3/debian/changelog cmake-3.16.3/debian/changelog
+--- cmake-3.16.3/debian/changelog 2020-03-16 19:09:14.000000000 +0900
++++ cmake-3.16.3/debian/changelog 2020-06-24 14:59:20.000000000 +0900
+@@ -1,3 +1,17 @@
++cmake (3.16.3-1.deb9moz1) jessie-backports; urgency=medium
++
++ * Mozilla backport for jessie.
++ * debian/rules, debian/control:
++ - Don't build against system libraries. libuv is missing on jessie, and
++ it's just simpler to disable the use of system libraries altogether.
++ - But still use system curl.
++ - Don't build a dbgsym package through dh_strip, that's not supported on
++ jessie.
++ * debian/compat: Restore a compat level of 10.
++ * debian/control: Remove versioned dependency on debhelper.
++
++ -- Mike Hommey <glandium@goemon> Wed, 24 Jun 2020 14:59:20 +0900
++
+ cmake (3.16.3-1~bpo9+1) stretch-backports; urgency=medium
+
+ * Rebuild for stretch-backports.
+diff -Nru cmake-3.16.3/debian/compat cmake-3.16.3/debian/compat
+--- cmake-3.16.3/debian/compat 1970-01-01 09:00:00.000000000 +0900
++++ cmake-3.16.3/debian/compat 2020-06-24 14:57:28.000000000 +0900
+@@ -0,0 +1 @@
++10
+diff -Nru cmake-3.16.3/debian/control cmake-3.16.3/debian/control
+--- cmake-3.16.3/debian/control 2020-03-16 19:09:14.000000000 +0900
++++ cmake-3.16.3/debian/control 2020-06-24 14:59:20.000000000 +0900
+@@ -4,17 +4,10 @@
+ Maintainer: Debian CMake Team <pkg-cmake-team@lists.alioth.debian.org>
+ Uploaders: Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>,
+ Felix Geyer <fgeyer@debian.org>
+-Build-Depends: debhelper-compat (= 12),
++Build-Depends: debhelper,
+ freebsd-glue [kfreebsd-any],
+- libarchive-dev (>= 3.3.3),
+- libbz2-dev,
+ libcurl4-openssl-dev | libcurl-ssl-dev,
+- libexpat1-dev,
+- libjsoncpp-dev,
+- liblzma-dev,
+ libncurses5-dev,
+- librhash-dev,
+- libuv1-dev (>= 1.10),
+ procps [!hurd-any],
+ python3-sphinx,
+ qtbase5-dev <!stage1>,
+diff -Nru cmake-3.16.3/debian/rules cmake-3.16.3/debian/rules
+--- cmake-3.16.3/debian/rules 2020-03-16 19:09:14.000000000 +0900
++++ cmake-3.16.3/debian/rules 2020-06-24 14:59:20.000000000 +0900
+@@ -45,7 +45,7 @@
+ override_dh_auto_configure: $(BUILD_FLAGS_FILE)
+ rm -rf Build && mkdir -p Build
+ cd Build && ../bootstrap --prefix=/usr --docdir=/share/doc/cmake --mandir=/share/man \
+- --init=../$(BUILD_FLAGS_FILE) --system-libs \
++ --init=../$(BUILD_FLAGS_FILE) --system-curl \
+ --sphinx-man --sphinx-html --sphinx-flags="-D today=\"$(BUILD_DATE)\"" \
+ $(BOOTSTRAP_PARALLEL) --verbose
+
+@@ -71,9 +71,6 @@
+ override_dh_sphinxdoc:
+ dh_sphinxdoc -pcmake-doc
+
+-override_dh_strip:
+- dh_strip --dbgsym-migration='cmake-dbg (<< 3.5.0-1~)'
+-
+ %:
+ dh $@ --with=sphinxdoc --builddirectory=Build
+