summaryrefslogtreecommitdiffstats
path: root/dom/webidl/ElementInternals.webidl
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--dom/webidl/ElementInternals.webidl13
1 files changed, 13 insertions, 0 deletions
diff --git a/dom/webidl/ElementInternals.webidl b/dom/webidl/ElementInternals.webidl
new file mode 100644
index 0000000000..c63c46d186
--- /dev/null
+++ b/dom/webidl/ElementInternals.webidl
@@ -0,0 +1,13 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://html.spec.whatwg.org/#elementinternals
+ */
+
+[Pref="dom.webcomponents.formAssociatedCustomElement.enabled", Exposed=Window]
+interface ElementInternals {
+};
+