summaryrefslogtreecommitdiffstats
path: root/gfx/wgpu/dummy
diff options
context:
space:
mode:
Diffstat (limited to 'gfx/wgpu/dummy')
-rw-r--r--gfx/wgpu/dummy/Cargo.toml16
-rw-r--r--gfx/wgpu/dummy/README.md3
-rw-r--r--gfx/wgpu/dummy/src/lib.rs3
3 files changed, 22 insertions, 0 deletions
diff --git a/gfx/wgpu/dummy/Cargo.toml b/gfx/wgpu/dummy/Cargo.toml
new file mode 100644
index 0000000000..3d253f05ed
--- /dev/null
+++ b/gfx/wgpu/dummy/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "dummy"
+version = "0.1.0"
+authors = [
+ "Dzmitry Malyshau <kvark@mozilla.com>",
+]
+edition = "2018"
+publish = false
+
+[features]
+
+[dependencies.wgc]
+path = "../wgpu-core"
+package = "wgpu-core"
+version = "0.6"
+features = ["serial-pass", "trace"]
diff --git a/gfx/wgpu/dummy/README.md b/gfx/wgpu/dummy/README.md
new file mode 100644
index 0000000000..5a95a787a5
--- /dev/null
+++ b/gfx/wgpu/dummy/README.md
@@ -0,0 +1,3 @@
+# wgpu dummy
+
+This is a dummy build target that makes `cargo check` and `cargo test` in the workspace to cover all the API.
diff --git a/gfx/wgpu/dummy/src/lib.rs b/gfx/wgpu/dummy/src/lib.rs
new file mode 100644
index 0000000000..e0032240a4
--- /dev/null
+++ b/gfx/wgpu/dummy/src/lib.rs
@@ -0,0 +1,3 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */