summaryrefslogtreecommitdiffstats
path: root/gfx/wgpu_bindings/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'gfx/wgpu_bindings/Cargo.toml')
-rw-r--r--gfx/wgpu_bindings/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/gfx/wgpu_bindings/Cargo.toml b/gfx/wgpu_bindings/Cargo.toml
new file mode 100644
index 0000000000..43f2287a71
--- /dev/null
+++ b/gfx/wgpu_bindings/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+name = "wgpu_bindings"
+version = "0.1.0"
+authors = [
+ "Dzmitry Malyshau <kvark@mozilla.com>",
+ "Joshua Groves <josh@joshgroves.com>",
+]
+edition = "2018"
+license = "MPL-2.0"
+publish = false
+
+[lib]
+
+[features]
+default = []
+
+[dependencies.wgc]
+path = "../wgpu/wgpu-core"
+package = "wgpu-core"
+features = ["replay", "trace", "serial-pass"]
+
+[dependencies.wgt]
+path = "../wgpu/wgpu-types"
+package = "wgpu-types"
+
+[dependencies]
+bincode = "1"
+log = "0.4"
+parking_lot = "0.11"
+serde = "1"