summaryrefslogtreecommitdiffstats
path: root/js/src/rust/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'js/src/rust/Cargo.toml')
-rw-r--r--js/src/rust/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/js/src/rust/Cargo.toml b/js/src/rust/Cargo.toml
new file mode 100644
index 0000000000..659967daf8
--- /dev/null
+++ b/js/src/rust/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "jsrust"
+version = "0.1.0"
+authors = ["The Spidermonkey developers"]
+
+[lib]
+name = "jsrust"
+crate-type = ["staticlib"]
+path = "lib.rs"
+
+[features]
+cranelift_x86 = ['jsrust_shared/cranelift_x86']
+cranelift_arm32 = ['jsrust_shared/cranelift_arm32']
+cranelift_arm64 = ['jsrust_shared/cranelift_arm64']
+cranelift_none = ['jsrust_shared/cranelift_none']
+simd-accel = ['jsrust_shared/simd-accel']
+smoosh = ['jsrust_shared/smoosh']
+
+[dependencies]
+jsrust_shared = { path = "./shared" }
+# Workaround for https://github.com/rust-lang/rust/issues/58393
+mozglue-static = { path = "../../../mozglue/static/rust" }
+wat = { version = "1.0.33" }
+wasmparser = { version = "0.48.2" }