summaryrefslogtreecommitdiffstats
path: root/mobile/android/confvars.sh
diff options
context:
space:
mode:
Diffstat (limited to 'mobile/android/confvars.sh')
-rw-r--r--mobile/android/confvars.sh34
1 files changed, 34 insertions, 0 deletions
diff --git a/mobile/android/confvars.sh b/mobile/android/confvars.sh
new file mode 100644
index 0000000000..70e13c85b2
--- /dev/null
+++ b/mobile/android/confvars.sh
@@ -0,0 +1,34 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+MOZ_APP_VENDOR=Mozilla
+
+MOZ_APP_UA_NAME=Firefox
+
+BROWSER_CHROME_URL=chrome://browser/content/browser.xul
+
+MOZ_BRANDING_DIRECTORY=mobile/android/branding/unofficial
+MOZ_OFFICIAL_BRANDING_DIRECTORY=mobile/android/branding/official
+# MOZ_APP_DISPLAYNAME is set by branding/configure.sh
+
+# We support Android SDK version 16 and up by default.
+# See the --enable-android-min-sdk and --enable-android-max-sdk arguments in configure.in.
+#
+# Warning: Before increasing the with-android-min-sdk value, please note several places in and out
+# of tree have to be changed. Otherwise, places like Treeherder or archive.mozilla.org will
+# advertise a bad API level. This may confuse people. As an example, please look at bug 1384482.
+# If you think you can't handle the whole set of changes, please reach out to the Release
+# Engineering team.
+MOZ_ANDROID_MIN_SDK_VERSION=16
+
+# There are several entry points into the Firefox application. These are the names of some of the classes that are
+# listed in the Android manifest. They are specified in here to avoid hard-coding them in source code files.
+MOZ_ANDROID_APPLICATION_CLASS=org.mozilla.gecko.GeckoApplication
+MOZ_ANDROID_BROWSER_INTENT_CLASS=org.mozilla.gecko.BrowserApp
+
+MOZ_NO_SMART_CARDS=1
+
+MOZ_RAW=1
+
+MOZ_APP_ID={aa3c5121-dab2-40e2-81ca-7ea25febc110}