summaryrefslogtreecommitdiffstats
path: root/remote/test/puppeteer/test-browser
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--remote/test/puppeteer/test-browser/connection.spec.js55
-rw-r--r--remote/test/puppeteer/test-browser/debug.spec.js65
-rw-r--r--remote/test/puppeteer/test-browser/helper.js27
3 files changed, 147 insertions, 0 deletions
diff --git a/remote/test/puppeteer/test-browser/connection.spec.js b/remote/test/puppeteer/test-browser/connection.spec.js
new file mode 100644
index 0000000000..eef8fe3c21
--- /dev/null
+++ b/remote/test/puppeteer/test-browser/connection.spec.js
@@ -0,0 +1,55 @@
+/**
+ * Copyright 2020 Google Inc. All rights reserved.
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+import { Connection } from '../lib/esm/puppeteer/common/Connection.js';
+import { BrowserWebSocketTransport } from '../lib/esm/puppeteer/common/BrowserWebSocketTransport.js';
+import puppeteer from '../lib/esm/puppeteer/web.js';
+import expect from '../node_modules/expect/build-es5/index.js';
+import { getWebSocketEndpoint } from './helper.js';
+
+describe('creating a Connection', () => {
+ it('can create a real connection to the backend and send messages', async () => {
+ const wsUrl = getWebSocketEndpoint();
+ const transport = await BrowserWebSocketTransport.create(wsUrl);
+
+ const connection = new Connection(wsUrl, transport);
+ const result = await connection.send('Browser.getVersion');
+ /* We can't expect exact results as the version of Chrome/CDP might change
+ * and we don't want flakey tests, so let's assert the structure, which is
+ * enough to confirm the result was recieved successfully.
+ */
+ expect(result).toEqual({
+ protocolVersion: expect.any(String),
+ jsVersion: expect.any(String),
+ revision: expect.any(String),
+ userAgent: expect.any(String),
+ product: expect.any(String),
+ });
+ });
+});
+
+describe('puppeteer.connect', () => {
+ it('can connect over websocket and make requests to the backend', async () => {
+ const wsUrl = getWebSocketEndpoint();
+ const browser = await puppeteer.connect({
+ browserWSEndpoint: wsUrl,
+ });
+
+ const version = await browser.version();
+ const versionLooksCorrect = /.+Chrome\/\d{2}/.test(version);
+ expect(version).toEqual(expect.any(String));
+ expect(versionLooksCorrect).toEqual(true);
+ });
+});
diff --git a/remote/test/puppeteer/test-browser/debug.spec.js b/remote/test/puppeteer/test-browser/debug.spec.js
new file mode 100644
index 0000000000..971d3a5346
--- /dev/null
+++ b/remote/test/puppeteer/test-browser/debug.spec.js
@@ -0,0 +1,65 @@
+/**
+ * Copyright 2020 Google Inc. All rights reserved.
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+import { debug } from '../lib/esm/puppeteer/common/Debug.js';
+import expect from '../node_modules/expect/build-es5/index.js';
+
+describe('debug', () => {
+ let originalLog;
+ let logs;
+ beforeEach(() => {
+ originalLog = console.log;
+ logs = [];
+ console.log = (...args) => {
+ logs.push(args);
+ };
+ });
+
+ afterEach(() => {
+ console.log = originalLog;
+ });
+
+ it('should return a function', async () => {
+ expect(debug('foo')).toBeInstanceOf(Function);
+ });
+
+ it('does not log to the console if __PUPPETEER_DEBUG global is not set', async () => {
+ const debugFn = debug('foo');
+ debugFn('lorem', 'ipsum');
+
+ expect(logs.length).toEqual(0);
+ });
+
+ it('logs to the console if __PUPPETEER_DEBUG global is set to *', async () => {
+ globalThis.__PUPPETEER_DEBUG = '*';
+ const debugFn = debug('foo');
+ debugFn('lorem', 'ipsum');
+
+ expect(logs.length).toEqual(1);
+ expect(logs).toEqual([['foo:', 'lorem', 'ipsum']]);
+ });
+
+ it('logs only messages matching the __PUPPETEER_DEBUG prefix', async () => {
+ globalThis.__PUPPETEER_DEBUG = 'foo';
+ const debugFoo = debug('foo');
+ const debugBar = debug('bar');
+ debugFoo('a');
+ debugBar('b');
+
+ expect(logs.length).toEqual(1);
+ expect(logs).toEqual([['foo:', 'a']]);
+ });
+});
diff --git a/remote/test/puppeteer/test-browser/helper.js b/remote/test/puppeteer/test-browser/helper.js
new file mode 100644
index 0000000000..6cfbe934d5
--- /dev/null
+++ b/remote/test/puppeteer/test-browser/helper.js
@@ -0,0 +1,27 @@
+/**
+ * Copyright 2020 Google Inc. All rights reserved.
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+/**
+ * Returns the web socket endpoint for the backend of the browser the tests run
+ * in. Used to create connections to that browser in Puppeteer for unit tests.
+ *
+ * It's available on window.__ENV__ because setup code in
+ * web-test-runner.config.js puts it there. If you're changing this code (or
+ * that code), make sure the other is updated accordingly.
+ */
+export function getWebSocketEndpoint() {
+ return window.__ENV__.wsEndpoint;
+}