summaryrefslogtreecommitdiffstats
path: root/services/fxaccounts/rust-bridge/firefox-accounts-bridge/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'services/fxaccounts/rust-bridge/firefox-accounts-bridge/Cargo.toml')
-rw-r--r--services/fxaccounts/rust-bridge/firefox-accounts-bridge/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/services/fxaccounts/rust-bridge/firefox-accounts-bridge/Cargo.toml b/services/fxaccounts/rust-bridge/firefox-accounts-bridge/Cargo.toml
new file mode 100644
index 0000000000..571cd94047
--- /dev/null
+++ b/services/fxaccounts/rust-bridge/firefox-accounts-bridge/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "firefox-accounts-bridge"
+version = "0.1.0"
+authors = ["The Synced Clients Integrations team <sync-team@mozilla.com>"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+atomic_refcell = "0.1"
+cstr = "0.2"
+libc = "0.2"
+once_cell = "1"
+paste = "0.1"
+serde = "1"
+serde_json = "1"
+url = "2.1"
+moz_task = { path = "../../../../xpcom/rust/moz_task" }
+nserror = { path = "../../../../xpcom/rust/nserror" }
+nsstring = { path = "../../../../xpcom/rust/nsstring" }
+xpcom = { path = "../../../../xpcom/rust/xpcom" }
+storage_variant = { path = "../../../../storage/variant" }
+thin-vec = { version = "0.2.1", features = ["gecko-ffi"] }
+fxa-client = { git = "https://github.com/mozilla/application-services", rev = "8a576fbe79199fa8664f64285524017f74ebcc5f", features = ["gecko"] }