summaryrefslogtreecommitdiffstats
path: root/servo/components/style/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--servo/components/style/Cargo.toml90
1 files changed, 90 insertions, 0 deletions
diff --git a/servo/components/style/Cargo.toml b/servo/components/style/Cargo.toml
new file mode 100644
index 0000000000..95ebd60c1a
--- /dev/null
+++ b/servo/components/style/Cargo.toml
@@ -0,0 +1,90 @@
+[package]
+name = "style"
+version = "0.0.1"
+authors = ["The Servo Project Developers"]
+license = "MPL-2.0"
+publish = false
+
+build = "build.rs"
+edition = "2018"
+
+# https://github.com/rust-lang/cargo/issues/3544
+links = "servo_style_crate"
+
+[lib]
+name = "style"
+path = "lib.rs"
+doctest = false
+
+[features]
+gecko = ["nsstring", "serde", "style_traits/gecko", "fallible/known_system_malloc", "bindgen", "regex", "toml"]
+servo = ["serde", "style_traits/servo", "servo_atoms", "servo_config", "html5ever",
+ "cssparser/serde", "encoding_rs", "malloc_size_of/servo", "arrayvec/use_union",
+ "servo_url", "string_cache", "to_shmem/servo", "servo_arc/servo"]
+servo-layout-2013 = []
+servo-layout-2020 = []
+gecko_debug = []
+gecko_refcount_logging = []
+gecko_profiler = []
+
+[dependencies]
+app_units = "0.7"
+arrayvec = "0.5"
+atomic_refcell = "0.1"
+bitflags = "1.0"
+byteorder = "1.0"
+cssparser = "0.28"
+derive_more = "0.99"
+new_debug_unreachable = "1.0"
+encoding_rs = {version = "0.8", optional = true}
+euclid = "0.22"
+fallible = { path = "../fallible" }
+fxhash = "0.2"
+hashbrown = "0.9"
+hashglobe = { path = "../hashglobe" }
+html5ever = {version = "0.24", optional = true}
+indexmap = {version = "1.0", features = ["std"]}
+itertools = "0.8"
+itoa = "0.4"
+lazy_static = "1"
+log = "0.4"
+malloc_size_of = { path = "../malloc_size_of" }
+malloc_size_of_derive = "0.1"
+matches = "0.1"
+nsstring = {path = "../../../xpcom/rust/nsstring/", optional = true}
+num_cpus = {version = "1.1.0"}
+num-integer = "0.1"
+num-traits = "0.2"
+num-derive = "0.3"
+owning_ref = "0.4"
+parking_lot = "0.11"
+precomputed-hash = "0.1.1"
+rayon = "1.5"
+selectors = { path = "../selectors" }
+serde = {version = "1.0", optional = true, features = ["derive"]}
+servo_arc = { path = "../servo_arc" }
+servo_atoms = {path = "../atoms", optional = true}
+servo_config = {path = "../config", optional = true}
+smallbitvec = "2.3.0"
+smallvec = "1.0"
+static_prefs = { path = "../../../modules/libpref/init/static_prefs" }
+string_cache = { version = "0.8", optional = true }
+style_derive = {path = "../style_derive"}
+style_traits = {path = "../style_traits"}
+servo_url = {path = "../url", optional = true}
+thin-slice = "0.1.0"
+to_shmem = {path = "../to_shmem"}
+to_shmem_derive = {path = "../to_shmem_derive"}
+time = "0.1"
+uluru = "0.4"
+unicode-bidi = "0.3"
+unicode-segmentation = "1.0"
+void = "1.0.2"
+
+[build-dependencies]
+lazy_static = "1"
+log = "0.4"
+bindgen = {version = "0.56", optional = true, default-features = false}
+regex = {version = "1.0", optional = true, default-features = false, features = ["perf", "std"]}
+walkdir = "2.1.4"
+toml = {version = "0.4.5", optional = true, default-features = false}