summaryrefslogtreecommitdiffstats
path: root/servo/ports/geckolib/tests/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--servo/ports/geckolib/tests/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/servo/ports/geckolib/tests/Cargo.toml b/servo/ports/geckolib/tests/Cargo.toml
new file mode 100644
index 0000000000..663b205333
--- /dev/null
+++ b/servo/ports/geckolib/tests/Cargo.toml
@@ -0,0 +1,27 @@
+[package]
+name = "stylo_tests"
+version = "0.0.1"
+authors = ["The Servo Project Developers"]
+license = "MPL-2.0"
+
+[lib]
+name = "stylo_tests"
+path = "lib.rs"
+doctest = false
+
+[dependencies]
+atomic_refcell = "0.1"
+cssparser = "0.28"
+cstr = "0.2"
+env_logger = { version = "0.8", default-features = false }
+geckoservo = {path = "../../../ports/geckolib"}
+libc = "0.2"
+log = {version = "0.4", features = ["release_max_level_info"]}
+malloc_size_of = {path = "../../../components/malloc_size_of"}
+num-traits = "0.2"
+selectors = {path = "../../../components/selectors"}
+size_of_test = {path = "../../../components/size_of_test"}
+smallvec = "1.0"
+style_traits = {path = "../../../components/style_traits"}
+style = {path = "../../../components/style", features = ["gecko"]}
+to_shmem = {path = "../../../components/to_shmem"}