summaryrefslogtreecommitdiffstats
path: root/third_party/python/attrs/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/python/attrs/pyproject.toml')
-rw-r--r--third_party/python/attrs/pyproject.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/third_party/python/attrs/pyproject.toml b/third_party/python/attrs/pyproject.toml
new file mode 100644
index 0000000000..5657791dfd
--- /dev/null
+++ b/third_party/python/attrs/pyproject.toml
@@ -0,0 +1,36 @@
+[build-system]
+requires = ["setuptools>=40.6.0", "wheel"]
+build-backend = "setuptools.build_meta"
+
+
+[tool.black]
+line-length = 79
+
+
+[tool.towncrier]
+ package = "attr"
+ package_dir = "src"
+ filename = "CHANGELOG.rst"
+ template = "changelog.d/towncrier_template.rst"
+ issue_format = "`#{issue} <https://github.com/python-attrs/attrs/issues/{issue}>`_"
+ directory = "changelog.d"
+ title_format = "{version} ({project_date})"
+ underlines = ["-", "^"]
+
+ [[tool.towncrier.section]]
+ path = ""
+
+ [[tool.towncrier.type]]
+ directory = "breaking"
+ name = "Backward-incompatible Changes"
+ showcontent = true
+
+ [[tool.towncrier.type]]
+ directory = "deprecation"
+ name = "Deprecations"
+ showcontent = true
+
+ [[tool.towncrier.type]]
+ directory = "change"
+ name = "Changes"
+ showcontent = true