summaryrefslogtreecommitdiffstats
path: root/third_party/python/diskcache/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/python/diskcache/setup.py')
-rw-r--r--third_party/python/diskcache/setup.py51
1 files changed, 51 insertions, 0 deletions
diff --git a/third_party/python/diskcache/setup.py b/third_party/python/diskcache/setup.py
new file mode 100644
index 0000000000..90dc280b27
--- /dev/null
+++ b/third_party/python/diskcache/setup.py
@@ -0,0 +1,51 @@
+from io import open
+from setuptools import setup
+from setuptools.command.test import test as TestCommand
+
+import diskcache
+
+
+class Tox(TestCommand):
+ def finalize_options(self):
+ TestCommand.finalize_options(self)
+ self.test_args = []
+ self.test_suite = True
+ def run_tests(self):
+ import tox
+ errno = tox.cmdline(self.test_args)
+ exit(errno)
+
+
+with open('README.rst', encoding='utf-8') as reader:
+ readme = reader.read()
+
+setup(
+ name=diskcache.__title__,
+ version=diskcache.__version__,
+ description='Disk Cache -- Disk and file backed persistent cache.',
+ long_description=readme,
+ author='Grant Jenks',
+ author_email='contact@grantjenks.com',
+ url='http://www.grantjenks.com/docs/diskcache/',
+ license='Apache 2.0',
+ packages=['diskcache'],
+ tests_require=['tox'],
+ cmdclass={'test': Tox},
+ install_requires=[],
+ classifiers=(
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Natural Language :: English',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
+ ),
+)