summaryrefslogtreecommitdiffstats
path: root/third_party/rust/crc32fast/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/crc32fast/Cargo.toml')
-rw-r--r--third_party/rust/crc32fast/Cargo.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/third_party/rust/crc32fast/Cargo.toml b/third_party/rust/crc32fast/Cargo.toml
new file mode 100644
index 0000000000..ca8bbcc1e7
--- /dev/null
+++ b/third_party/rust/crc32fast/Cargo.toml
@@ -0,0 +1,41 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "crc32fast"
+version = "1.2.0"
+authors = ["Sam Rijs <srijs@airpost.net>", "Alex Crichton <alex@alexcrichton.com>"]
+description = "Fast, SIMD-accelerated CRC32 (IEEE) checksum computation"
+readme = "README.md"
+keywords = ["checksum", "crc", "crc32", "simd", "fast"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/srijs/rust-crc32fast"
+
+[[bench]]
+name = "bench"
+harness = false
+[dependencies.cfg-if]
+version = "0.1"
+[dev-dependencies.bencher]
+version = "0.1"
+
+[dev-dependencies.quickcheck]
+version = "0.6"
+default-features = false
+
+[dev-dependencies.rand]
+version = "0.4"
+
+[features]
+default = ["std"]
+nightly = []
+std = []