summaryrefslogtreecommitdiffstats
path: root/third_party/rust/crossbeam-channel/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/crossbeam-channel/Cargo.toml')
-rw-r--r--third_party/rust/crossbeam-channel/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/third_party/rust/crossbeam-channel/Cargo.toml b/third_party/rust/crossbeam-channel/Cargo.toml
new file mode 100644
index 0000000000..a5c9964af3
--- /dev/null
+++ b/third_party/rust/crossbeam-channel/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "crossbeam-channel"
+version = "0.5.0"
+authors = ["The Crossbeam Project Developers"]
+description = "Multi-producer multi-consumer channels for message passing"
+homepage = "https://github.com/crossbeam-rs/crossbeam/tree/master/crossbeam-channel"
+documentation = "https://docs.rs/crossbeam-channel"
+readme = "README.md"
+keywords = ["channel", "mpmc", "select", "golang", "message"]
+categories = ["algorithms", "concurrency", "data-structures"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/crossbeam-rs/crossbeam"
+[dependencies.cfg-if]
+version = "1"
+
+[dependencies.crossbeam-utils]
+version = "0.8"
+optional = true
+default-features = false
+[dev-dependencies.num_cpus]
+version = "1.13.0"
+
+[dev-dependencies.rand]
+version = "0.7.3"
+
+[dev-dependencies.signal-hook]
+version = "0.1.15"
+
+[features]
+default = ["std"]
+std = ["crossbeam-utils/std"]