summaryrefslogtreecommitdiffstats
path: root/third_party/rust/crossbeam-queue/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/crossbeam-queue/Cargo.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/third_party/rust/crossbeam-queue/Cargo.toml b/third_party/rust/crossbeam-queue/Cargo.toml
new file mode 100644
index 0000000000..cfbb057a1e
--- /dev/null
+++ b/third_party/rust/crossbeam-queue/Cargo.toml
@@ -0,0 +1,28 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "crossbeam-queue"
+version = "0.1.2"
+authors = ["The Crossbeam Project Developers"]
+description = "Concurrent queues"
+homepage = "https://github.com/crossbeam-rs/crossbeam/tree/master/crossbeam-utils"
+documentation = "https://docs.rs/crossbeam-queue"
+readme = "README.md"
+keywords = ["queue", "mpmc", "lock-free", "producer", "consumer"]
+categories = ["concurrency", "data-structures"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/crossbeam-rs/crossbeam"
+[dependencies.crossbeam-utils]
+version = "0.6.5"
+[dev-dependencies.rand]
+version = "0.6"