summaryrefslogtreecommitdiffstats
path: root/third_party/rust/d3d12/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/d3d12/Cargo.toml')
-rw-r--r--third_party/rust/d3d12/Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/third_party/rust/d3d12/Cargo.toml b/third_party/rust/d3d12/Cargo.toml
new file mode 100644
index 0000000000..9884e7608c
--- /dev/null
+++ b/third_party/rust/d3d12/Cargo.toml
@@ -0,0 +1,37 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "d3d12"
+version = "0.3.0"
+authors = ["msiglreith <m.siglreith@gmail.com>", "Dzmitry Malyshau <kvarkus@gmail.com>"]
+description = "Low level D3D12 API wrapper"
+documentation = "https://docs.rs/d3d12"
+keywords = ["windows", "graphics"]
+categories = ["memory-management"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/gfx-rs/d3d12-rs"
+[package.metadata.docs.rs]
+default-target = "x86_64-pc-windows-msvc"
+[dependencies.bitflags]
+version = "1"
+
+[dependencies.libloading]
+version = "0.5"
+optional = true
+
+[dependencies.winapi]
+version = "0.3"
+features = ["dxgi1_2", "dxgi1_3", "dxgi1_4", "dxgidebug", "d3d12", "d3d12sdklayers", "d3dcommon", "d3dcompiler", "dxgiformat", "synchapi", "winerror"]
+
+[features]
+implicit-link = []